If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

File|Open File caused crash.

VERIFIED DUPLICATE of bug 46849

Status

SeaMonkey
General
P3
critical
VERIFIED DUPLICATE of bug 46849
17 years ago
13 years ago

People

(Reporter: leger, Assigned: Chris McAfee)

Tracking

({crash})

Trunk
Other
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Overview Description: 
Latest M17 branch build crashing randomly.  File|Open File crash only seen once 
today.

Steps to Reproduce: 
1) Install 2000-07-31-04-M17 Linux
2) Launch Netscape 6 application
3) Select File|Open File

Actual Results: Crash

Expected Results: Should go to Open File window.

Reproducibility: Intermittent.

Additional Builds and Platforms Tested On: 
Checking Mac now...will check Win32 July 31 build when out.

Additional Information: 
Talkback Incident ID#15063358
 Trigger Type:  Program Crash 

 Trigger Reason:  SIGSEGV: Segmentation Fault: (signal 11) 

 Call Stack:    (Signature = nsXBLBinding::InitClass() 9fee3cc2) 
     
   nsXBLBinding::InitClass() 
                                                      
     
   nsXBLBinding::InstallProperties() 
                                                      
     
   nsXBLService::LoadBindings() 
                                                      
     
   nsCSSFrameConstructor::ConstructFrameInternal() 
                                                      
     
   nsCSSFrameConstructor::ConstructFrame() 
                                                      
     
   nsCSSFrameConstructor::ProcessChildren() 
                                                      
     
   nsCSSFrameConstructor::ConstructXULFrame() 
                                                      
     
   nsCSSFrameConstructor::ConstructFrameInternal() 
                                                      
     
   nsCSSFrameConstructor::ConstructFrame() 
                                                      
     
   nsCSSFrameConstructor::ProcessChildren() 
                                                      
     
   nsCSSFrameConstructor::ConstructDocElementFrame() 
                                                      
     
   nsCSSFrameConstructor::ContentInserted() 
                                                      
     
   StyleSetImpl::ContentInserted() 
                                                      
     
   PresShell::InitialReflow() 
                                                      
     
   nsXULDocument::StartLayout() 
                                                      
     
   nsXULDocument::ResumeWalk() 
                                                      
     
   nsXULDocument::OnStreamComplete() 
                                                      
     
   nsStreamLoader::OnStopRequest() 
                                                      
     
   nsResChannel::EndRequest() 
                                                      
     
   nsResChannel::OnStopRequest() 
                                                      
     
   nsFileChannel::OnStopRequest() 
                                                      
     
   nsOnStopRequestEvent::HandleEvent() 
                                                      
     
   nsStreamListenerEvent::HandlePLEvent() 
                                                      
     
   PL_HandleEvent() 
                                                      
     
   PL_ProcessPendingEvents() 
                                                      
     
   nsEventQueueImpl::ProcessPendingEvents() 
                                                      
     
   event_processor_callback() 
                                                      
     
   our_gdk_io_invoke() 
                                                      
     
   libglib-1.2.so.0 + 0xe52a (0x404ac52a) 
                                                      
     
   libglib-1.2.so.0 + 0xfbe6 (0x404adbe6) 
                                                      
     
   libglib-1.2.so.0 + 0x101a1 (0x404ae1a1) 
                                                      
     
   libglib-1.2.so.0 + 0x10254 (0x404ae254) 
                                                      
     
   nsAppShell::DispatchNativeEvent() 
                                                      
     
   nsXULWindow::ShowModal() 
                                                      
     
   nsWebShellWindow::ShowModal() 
                                                      
     
   nsChromeTreeOwner::ShowModal() 
                                                      
     
   GlobalWindowImpl::OpenInternal() 
                                                      
     
   GlobalWindowImpl::OpenDialog() 
                                                      
     
   WindowOpenDialog() 
                                                      
     
   js_Invoke() 
                                                      
     
   js_Interpret() 
                                                      
     
   js_Invoke() 
                                                      
     
   js_InternalInvoke() 
                                                      
     
   JS_CallFunctionValue() 
                                                      
     
   nsJSContext::CallEventHandler() 
                                                      
     
   nsJSEventListener::HandleEvent() 
                                                      
     
   nsEventListenerManager::HandleEventSubType() 
                                                      
     
   nsEventListenerManager::HandleEvent() 
                                                      
     
   nsXULElement::HandleDOMEvent() 
                                                      
     
   PresShell::HandleDOMEventWithTarget() 
                                                      
     
   nsMenuFrame::Execute() 
                                                      
     
   nsMenuFrame::HandleEvent() 
                                                      
     
   PresShell::HandleEventInternal() 
                                                      
     
   PresShell::HandleEvent() 
                                                      
     
   nsView::HandleEvent() 
                                                      
     
   nsView::HandleEvent() 
                                                      
     
   nsView::HandleEvent() 
                                                      
     
   nsView::HandleEvent() 
                                                      
     
   nsViewManager2::DispatchEvent() 
                                                      
     
   HandleEvent() 
                                                      
     
   nsWidget::DispatchEvent() 
                                                      
     
   nsWidget::DispatchWindowEvent() 
                                                      
     
   nsWidget::DispatchMouseEvent() 
                                                      
     
   nsWidget::OnButtonReleaseSignal() 
                                                      
     
   nsWindow::HandleGDKEvent() 
                                                      
     
   dispatch_superwin_event() 
                                                      
     
   handle_gdk_event() 
                                                      
     
   libgdk-1.2.so.0 + 0x1700b (0x4048300b) 
                                                      
     
   libglib-1.2.so.0 + 0xfbe6 (0x404adbe6) 
                                                      
     
   libglib-1.2.so.0 + 0x101a1 (0x404ae1a1) 
                                                      
     
   libglib-1.2.so.0 + 0x10341 (0x404ae341) 
                                                      
     
   libgtk-1.2.so.0 + 0x8c209 (0x403d8209) 
                                                      
     
   nsAppShell::Run() 
                                                      
     
   nsAppShellService::Run() 
                                                      
     
   main1() 
                                                      
     
   main() 
                                                      
     
   libc.so.6 + 0x181eb (0x402461eb)
(Reporter)

Comment 1

17 years ago
Putting on nsbeta2 nominee radar. Need to see if other folks can reproduce.
Keywords: nsbeta2
QA Contact: doronr → claudius
(Reporter)

Comment 2

17 years ago
2 more crashes with same Linux build getting same stack trace.
Incident # 15064221 - Random crashing every 2 or 3 minutes
Incident # 15063432 - Crash loading ftp://ftp.netscape.com 

2000-07-31-04-M17 Linux is todays branch candidate - yikes!
Keywords: crash

Comment 3

17 years ago
Dup of bug 46849?

Comment 4

17 years ago
This is a dup of bug 46849

*** This bug has been marked as a duplicate of 46849 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

17 years ago
Yes...marking Verified as a dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.