Closed Bug 468847 Opened 16 years ago Closed 16 years ago

RFE: Switch between 'Reply' and 'Reply All' from Compose Window (ala gmail)

Categories

(Thunderbird :: Message Compose Window, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 248681

People

(Reporter: josh, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: 

Often I will find that after I hit either reply-all or reply, and am typing my reply, that I wish I had hit the other button instead. 

Gmail's web interface offers a nice option to switch between 'reply' and 'reply-all' after one has started composing a message. Would love to see this in Thunderbird.

Usecase:
1. User hits Reply to a message
2. App displays Compose window with to: sender, and toolbar button 'Reply All'
3. User starts typing reply
4. User clicks 'Reply All' button
5. App adds all original recipients as CCs. If user has entered additional recipients, they are preserved. If a collision exists between the additional addresses and the added addresses, no duplication shall occur.
6. App changes state of button to read 'Reply' instead of 'Reply All'
7. User clicks 'Reply' button
8. App removes all original recipients from current message recipients, with the exception of the original sender. Any additional recipients entered by the user are preserved. 

All dupe checking/matching to be performed via exact string matching on email address portion of recipient.



Reproducible: Always
OS: Mac OS X → All
Hardware: PC → All
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
thanks... (I searched for "switch" but not "toggle").
You need to log in before you can comment on or make changes to this bug.