Closed Bug 468860 Opened 11 years ago Closed 10 years ago

class="plain" should turn off -moz-appearance too

Categories

(Toolkit :: Themes, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: neil, Assigned: mstange)

References

()

Details

Attachments

(1 file)

When class="plain" was invented it only turned off margin, borders and padding because -moz-appearance hadn't been invented yet. Now that we've added -moz-appearance to everything do we need class="plain" to turn that off too?

I also noticed that we have some (but not all) duplication between global.css button.css and textbox.css which we could eliminate at the same time.

Pinstripe would probably have to be dealt with separately.
Yeah, Pinstripe doesn't even use -moz-appearance for trees.
The plain class was intended originally only for labels which don't have native theming, as well as buttons and textboxes. It would be good however to have it apply to all elements however, so we should do this.

> Pinstripe would probably have to be dealt with separately.

Why?
Summary: class="plain" should turn off -moz-appearance too? → class="plain" should turn off -moz-appearance too
(In reply to comment #2)
> The plain class was intended originally only for labels which don't have native
> theming, as well as buttons and textboxes. It would be good however to have it
> apply to all elements however, so we should do this.
In fact it does apply to all elements, via the rule in global.css, although textboxes additionally apply -moz-appearance: none; to their copy.

> > Pinstripe would probably have to be dealt with separately.
> Why?
Sorry, I misread its button.css; there are no borders for it to override.
Attached patch just do itSplinter Review
Is there any reason to not just do this?
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #391798 - Flags: review?(neil)
Comment on attachment 391798 [details] [diff] [review]
just do it

Let's give it a whirl ;-)
Attachment #391798 - Flags: review?(neil) → review+
I guess we then need to look for places that emulate plain e.g. #downloadView
(In reply to comment #6)
> I guess we then need to look for places that emulate plain e.g. #downloadView

Bug 426917 says that on windows classic #downloadView shouldn't be plain.
http://hg.mozilla.org/mozilla-central/rev/0cd13b752ef9
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.