images blank when printing

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Patrick, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.4) Gecko/2008111319 Ubuntu/8.10 (intrepid) Firefox/3.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.4) Gecko/2008111319 Ubuntu/8.10 (intrepid) Firefox/3.0.4

when you print out some web pages, some images remain blank on the print media
- the images will show up in the print preview
- "print background images" option is checked
- i tracked it down and stored this self-explanatory html document at the url mentioned:

<html><head>

<title>div border vs. image printing / aka "How many Bulps are there ?"</title></head><body>

<!-- two cases of "vanishing images", both striped down to the minimum bug triggering requirements -->
<!-- when you print this page (cups/"print to pdf" will do), the first and and the second bulp will be missing -->
<!-- (hope you will be able to reproduce, as it's really tricky - e.g. the first bulp shows up if i
      change "width:800px" to "width:500px) -->
<!-- (i have no clue, why this happens) (discovered on google notebook for the curious) -->

<div style="width:800px">
<div style="border-top:1px solid">
<img src="http://www.hostanyimage.com/files/3tq1l4cs6dzxc3egq7r4.jpg">
</div></div>

<div style="border-left:1px solid;border-bottom:1px solid">
<img src="http://www.hostanyimage.com/files/3tq1l4cs6dzxc3egq7r4.jpg">
</div>

<img src="http://www.hostanyimage.com/files/3tq1l4cs6dzxc3egq7r4.jpg">

</body></html>


Reproducible: Always
(Reporter)

Comment 2

10 years ago
Quick-Reproduction HOWTO:
1. go to http://stashbox.org/321179/notebook.html
2. Control-P
3. Print to pdf
4. $kpdf mozilla.pdf1. go to http://stashbox.org/321179/notebook.html

Comment 4

9 years ago
Could not reproduce in either Firefox 3.0.10 or Firefox 3.5preb5.
(Reporter)

Comment 5

9 years ago
Neither can I reproduce it at the moment... seems to be gone. This particular case at least... I can't exactly remember now but I think I had a similar issue again lately. Anyway - I won't mind if this bug was closed for now.

Comment 6

9 years ago
Just closed the Ubuntu bug as the reporter is no longer having issues with Firefox 3.0.11.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 3.0 Branch

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.