Closed Bug 469101 Opened 12 years ago Closed 12 years ago

End of comment not considered (gecko engine)

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 102127

People

(Reporter: r.lagrange, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

A end of comment markup is not considered by gecko, nor the embedded html viewer.
This issue appear after a lot of "-" in the comment.

Syntax seems to be ok (work great on webkit/IE, for example).
See http://echtelion.info/screensource.PNG for screenshot of the source code

Reproducible: Always

Steps to Reproduce:
1. start the page, log in the webapp
2. see a menu is not displayed, while displayed on ie/webkit
3. see source code (http://echtelion.info/screensource.PNG)
Actual Results:  
end of comment not considered, the html block is ignored.

Expected Results:  
html block parsed and displayed

Seems to appear after a serie of "-" chars.

deleting the "-" serie's make the html block be parsed
see  http://echtelion.info/screensourceOK.PNG


about:buildconfig

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-GL -wd4624 -wd4952 -TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	14.00.50727.762 	-GR- -GL -wd4624 -wd4952 -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-official-branding --enable-jemalloc --with-crashreporter-enable-percent=10
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 102127
See also bug 214476 for proposed change from SGML to HTML5 parsing.
You need to log in before you can comment on or make changes to this bug.