Closed Bug 469444 Opened 11 years ago Closed 11 years ago

runtests.py.in : set an explicit default |leakThreshold = 0| for a11y

Categories

(Testing :: Mochitest, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.1b3

People

(Reporter: sgautherie, Assigned: sgautherie)

References

Details

(Keywords: fixed1.9.1)

Attachments

(1 file)

Recently, bug 465755 happened;
now, while working on bug 468023, I noticed/wondered about this bug.

I'm guessing that a11y needs:
*__init__(), to support |--leak-threshold|.
*evaluateCommand(), to turn the box Orange (or whatever that function does).
Depends on: 424195
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20081211 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/0d2bceefc012)

Implicit to Explicit, for now;
will also allow to set a separate threshold if needed.
Attachment #352847 - Flags: review?
Attachment #352847 - Flags: review? → review?(ted.mielczarek)
Attachment #352847 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 352847 [details] [diff] [review]
(Av1) Explicitly set default leakThreshold to 0 in runtests.py.in
[Checkin: Comment 2]

http://hg.mozilla.org/mozilla-central/rev/5ab9ab1f0f03
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/bcc21e3fb68d
Attachment #352847 - Attachment description: (Av1) Explicitly set default leakThreshold to 0 in runtests.py.in → (Av1) Explicitly set default leakThreshold to 0 in runtests.py.in [Checkin: Comment 2]
Target Milestone: --- → mozilla1.9.1b3
Version: unspecified → Trunk
Assignee: nobody → sgautherie.bz
Blocks: 473259
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(In reply to comment #0)
> I'm guessing that a11y needs:
> *__init__(), to support |--leak-threshold|.
> *evaluateCommand(), to turn the box Orange (or whatever that function does).

It doesn't, because it inherits them from |class MozillaMochichrome| :->
(Forgive me,: I'm "learning" python and this file at the same time...)

Let me morph this bug to what I actually did.
No longer blocks: 473259
Severity: normal → minor
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
Summary: steps.py : MozillaA11YTest misses __init__() and evaluateCommand() → runtests.py.in : set an explicit default |leakThreshold = 0| for a11y
Blocks: 475085
You need to log in before you can comment on or make changes to this bug.