If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Move a temporary saved attachment to recycle bin after closing of Viewer

RESOLVED DUPLICATE of bug 220808

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 220808
9 years ago
9 years ago

People

(Reporter: Holger Jeromin, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Opera/9.63 (Windows NT 5.1; U; de) Presto/2.1.1
Build Identifier: version 2.0.0.18 (20081105)

Detect file changes after closing of a called program. 
Alternative thunderbird can simply move the file afterwards into recycle bin of windows.

Reproducible: Always

Steps to Reproduce:
1. receive Wordfile
2. open word by double clicking the attachment
3 [review]. change things and save the file in word (not save as...)
4. close word and thunderbird
Actual Results:  
The filechanges are lost, with no possibility to recover.

Expected Results:  
1. The changed tempfile should be recognised and user should be asked to move the file to own documents.

or

2. all tempdata should be moved to system recycle bin instead deleting them. So there is at least a possibility to recover the data.

or

3. lock the tempfile so no software can modify it. Ideally the programm would grump to the user if he wants to save his changes in the temp dir.

A variation of user error:
User receives wordfile, opens via tempfile, change, save and quit word. 
To send the changes back my father *forwarded* the (he thought) changed originalmail back to me.

Detection of a change in tempfile would have solved this error, too.
(Reporter)

Updated

9 years ago
Version: unspecified → 2.0

Comment 1

9 years ago
Not a problem with thunderbird3. Tmp files are opened readonly, so you won't loose anything.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 220808
You need to log in before you can comment on or make changes to this bug.