Status

defect
--
major
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: jmjjeffery, Assigned: dbaron)

Tracking

({regression})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.85])

Attachments

(1 attachment)

Look at the error console and see if there's an error saying "XUL box for %1$S element contained an inline %2$S child, forcing all its children to be wrapped in a block".  If so, what file, and what elements?
This in the Console2:

Warning: XUL box for window element contained an inline link child, forcing all its children to be wrapped in a block.
Source file: chrome://chatzilla/content/chatzilla.xul

Clicking the link to the source file give no further info...


Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20081217 Minefield/3.2a1pre Firefox/3.0.4 ID:20081217070445
Posted patch patchSplinter Review
This ought to fix it.
Attachment #353452 - Flags: review?(gijskruitbosch+bugs)
Blocks: 421203

Comment 4

11 years ago
(In reply to comment #3)
> Created an attachment (id=353452) [details]
> patch
> 
> This ought to fix it.

I don't like sounding like an idiot, but at the risk of it, why do we need this fix? Isn't html:link already supposed to be display:none? If not, what's its graphical representation? (I regret to say I know little about layout, so again, my questions may be wrongly phrased or misplaced, but I would like to be enlightened a little bit here)
html:head is display:none, and html:link is supposed to be inside html:head.

Comment 6

11 years ago
Comment on attachment 353452 [details] [diff] [review]
patch

Alright, thanks for clarifying. r=me, then
Attachment #353452 - Flags: review?(gijskruitbosch+bugs) → review+
Fix checked in to CVS trunk.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Not M-C ??

Its also broken - at least that's what I filed the bug under..
The fix is to Chatzilla, which is in CVS.
Would it make sense to add link { display:none } to html.css as a backstop against future instances of this problem?
I don't think so.  It would probably also break some of Hixie's tests...

Comment 12

11 years ago
(In reply to comment #9)
> The fix is to Chatzilla, which is in CVS.

Correct. This fix should be in .85, which may take a while to release. Meanwhile you can use trunk builds from CVS. SeaMonkey imports it from there, I believe. If that does not work for you, you can also install a nightly version once it appears on http://twpol.dyndns.org/mozilla/chatzilla/nightly/ (should be within the next hour or so)

(In reply to comment #10)
> Would it make sense to add link { display:none } to html.css as a backstop
> against future instances of this problem?

That would technically be a different bug, I think?

Related to that, David, can this bug be moved to ChatZilla (Other Apps) so we can find it more easily? It was fixed in our code, anyway. Thanks for your help in getting this fixed quickly, much appreciated! :-)
Whiteboard: [cz-0.9.85]

Comment 13

11 years ago
(In reply to comment #12)
> (In reply to comment #10)
> > Would it make sense to add link { display:none } to html.css as a backstop
> > against future instances of this problem?
> 
> That would technically be a different bug, I think?

Sorry about that, I'd reloaded the page - hence not getting mid-aired - without rereading for new comments; my bad!
Assignee: nobody → dbaron
Component: Layout → ChatZilla
Product: Core → Other Applications
QA Contact: layout → chatzilla
Latest nightly build from the link in comment #12 fixed Chatzilla on trunk-builds.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20081217 Minefield/3.2a1pre Firefox/3.0.4 ID:20081217070445

Updated

10 years ago
Duplicate of this bug: 490406

Updated

10 years ago
Duplicate of this bug: 490406
You need to log in before you can comment on or make changes to this bug.