Closed Bug 47015 Opened 22 years ago Closed 21 years ago

editor needs a way to ask layout what whitespace is significant

Categories

(Core :: DOM: Editor, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla0.9.1

People

(Reporter: mozeditor, Assigned: mozeditor)

References

Details

(Whiteboard: [whitespace][nsbeta3-][rtm-])

The rules for when whitespace in html actually renders and when it doesn't are 
odd, and their enforcement in layout has changed over time.  Since the editor 
doesnt have a way to ask layout abut this, bugs have appeared in the editor as 
layout changes it's whitespace policy.

This bug is a catchall for this issue: I'm duping several bugs to it.
*** Bug 42777 has been marked as a duplicate of this bug. ***
noinating for b3
Status: NEW → ASSIGNED
Keywords: nsbeta3
Target Milestone: --- → M18
*** Bug 42574 has been marked as a duplicate of this bug. ***
*** Bug 46209 has been marked as a duplicate of this bug. ***
*** Bug 43030 has been marked as a duplicate of this bug. ***
Nominating for nsbeta3+.  This bug has a high incidence of occurence, as seen by 
the number of duplicate bugs reported. Needs to be fixed in nsbeta3 window.

Adding Bob, Frank and Kat to cc: list.
Added correctness and nsbeta3+
Keywords: correctness
Whiteboard: nsbeta3+
Whiteboard: nsbeta3+ → {nsbeta3+}
Whiteboard: {nsbeta3+} → [nsbeta3+]
Priority: P3 → P1
Whiteboard: [nsbeta3+] → [nsbeta3+][p:1]
setting priority in status whiteboard
setting priority in status whiteboard
We need more info, but strongly suspect this is not a P1 bug.  Can you give us 
more info as to user experience here?
PDT: many users input whitespace for spacing between words, etc. The editor is 
inconsistent on how it handles those spaces (look at the dups). The reason this 
is P1, is because this will take some effort on Joe's part to iron out all of 
the issues. As a simple example -- if you entered spaces to resemble tabs in 
your document and they were all stripped out when you saved the file, would you 
be a little irritated?
PDT thinks this is a P3.
Priority: P1 → P3
Whiteboard: [nsbeta3+][p:1] → [nsbeta3+][p:1][PDTP3]
clearing out +, setting to - and moving to future per conversation with PDT team 
today
Severity: critical → major
Whiteboard: [nsbeta3+][p:1][PDTP3] → [nsbeta3-][p:1][PDTP3]
Target Milestone: M18 → Future
I'm disappointed this bug was marked as "future".

Many Japanese want to enter a full width space at the beginning of a line.
To do it is impossible is a serious bug(Bug 42574).
I also regard this bug as very serious.  There are architectual issues involved, 
and a lot of implementation work - all risky.  But the pain level of this problem 
is also extremely high.

Here is my current plan:  I'm marking m19, but not renominating for b3.  I want 
to continue to work on this problem and hope to get it in for RTM if I have made 
good progress that is heavily tested.  The good news here is that we should be 
able to tell if a solution is well behaved and make a good decision on inclusion 
for rtm.

cc'ing kin (since beth is out)
Target Milestone: Future → M19
Keywords: rtm
Priority: P3 → P1
Whiteboard: [nsbeta3-][p:1][PDTP3] → [rtm+][nsbeta3-][p:1]
setting to rtm+
Joe, please include the required information per the rtm checkin rules
Whiteboard: [rtm+][nsbeta3-][p:1] → [rtm+ NEED INFO][nsbeta3-][p:1]
removing + per pdt sw rules
Whiteboard: [rtm+ NEED INFO][nsbeta3-][p:1] → [rtm NEED INFO][nsbeta3-][p:1]
Whiteboard: [rtm NEED INFO][nsbeta3-][p:1] → [nsbeta3-]
Target Milestone: M19 → mozilla0.9
wont happen for rtm; moz 0.9
got moved out of m19, but neglected to rtm- it
Whiteboard: [nsbeta3-] → [nsbeta3-][rtm-]
Whitespace behaviouor of the edior is very odd and easy-to-run-in (assuming what
I see is this bug) - mozilla0.9 nomination.
Keywords: mozilla0.9
*** Bug 42574 has been marked as a duplicate of this bug. ***
Blocks: 65557
Additional Comments From jfrancis@netscape.com 2001-01-15 20:58 in bug 65557:
> 47015 is itself rather obsolete (I can't do what it proposes), but it has a
> bunch of dups to it that are real bugs and should be tested when I complete
> ws work.

Joe, can you please update this bug with the current state?
pushing off ws work to moz0.9.1 since it is not ready for prime time.
Interested parties should check out bug 65557, which has the patches.  We are
getting pretty close here.  
Target Milestone: mozilla0.9 → mozilla0.9.1
Target Milestone: mozilla0.9.1 → mozilla0.9.2
Whiteboard: [nsbeta3-][rtm-] → [whitespace][nsbeta3-][rtm-]
Target Milestone: mozilla0.9.2 → mozilla0.9.1
ws work has landed.  fireball of death now at end of runway.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
I followed these instructions from bug46209(which is a DUP of this bug):

ujay,

to test what i've done, use this document:

<html><body><ul><li> </li></ul></body></html>

Open that document in composer.  Before, you would get a list item that you 
couldn't click in.  Now, you should be able to click in the list item, and type, 
etc...


And I still cannot click in the list item.

REOPENING.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Thanks for testing the dups Sujay.  I need that coverage.  i've reopened the
specific bug that failed (46209) and reclosed this one.  Please do reopen any
other dups that fail.  Thanks!
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
verified.
You need to log in before you can comment on or make changes to this bug.