Firefox crashes if the second time I try to print in a session [@ libobjc.A.dylib@0x15688 - CanonIJPDE ]

VERIFIED DUPLICATE of bug 460963

Status

()

--
critical
VERIFIED DUPLICATE of bug 460963
10 years ago
10 years ago

People

(Reporter: ahnolds, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

When I try to open the print dialog in any fashion (file>print, apple-p) for the second time in a session, firefox crashes before opening the print dialouge.  This happens regardless of the webpage I am printing, regardless of the printer I am printing to, and regardless of what I have selected the first time I have opened the print dialogue (print, cancel, preview, etc).

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
2.Press apple-p
3.Choose something (doesn't matter, but cancel doesn't waste paper)
4.Press apple-p again
Actual Results:  
Firefox closes and the crash reporter pops up

Expected Results:  
Given me the print dialogue box and allowed me to print

Default 3.0.5 Theme for Mac OSX
Better Gmail 2 and Linkification addons
Default, Java Embedding 0.9.6.4, Quicktime 7.5.7, and Shockwave Flash Plugins
My default printer is a Canon Pixma MP610, but that does not seem relevant since I have this problem regardless of which printer I select
See Crash ID: 449f0401-0b1e-48bb-b629-0f9982081223 among others

Comment 1

10 years ago
It looks like it's dying inside the printer driver.

bp-449f0401-0b1e-48bb-b629-0f9982081223
0  	libobjc.A.dylib  	libobjc.A.dylib@0x15688  	
1 	CanonIJPDE 	CanonIJPDE@0x1531e 	
2 	CanonIJPDE 	CanonIJPDE@0x153e1 	
3 	CanonIJPDE 	CanonIJPDE@0x170e7 	
4 	CanonIJPDE 	CanonIJPDE@0x17020 	
5 	Foundation 	Foundation@0x9f1b 	
6 	CoreFoundation 	CoreFoundation@0x548d9 	
7 	CoreFoundation 	CoreFoundation@0x54bb2 	
8 	Foundation 	Foundation@0x707f 	
9 	Foundation 	Foundation@0x108c7 	
10 	CanonIJPDE 	CanonIJPDE@0x16bee 	
11 	CanonIJPDE 	CanonIJPDE@0x6ff6 	
12 	CanonIJPDE 	CanonIJPDE@0x15e6 	
13 	PrintCocoaUI 	PrintCocoaUI@0x63f8 	
14 	PrintCocoaUI 	PrintCocoaUI@0x4ae7 	
15 	PrintCocoaUI 	PrintCocoaUI@0x31a3 	
16 	PrintCocoaUI 	PrintCocoaUI@0x1873b 	
17 	PrintCocoaUI 	PrintCocoaUI@0x2275e 	
18 	AppKit 	AppKit@0xa8cad 	
19 	AppKit 	AppKit@0x46d09 	
20 	PrintCocoaUI 	PrintCocoaUI@0x1da9e 	
21 	PrintCocoaUI 	PrintCocoaUI@0xd57d 	
22 	Print 	Print@0x2a20 	
23 	XUL 	nsPrintingPromptService::ShowPrintDialog 	embedding/components/printingui/src/mac/nsPrintingPromptServiceX.mm:348
24 	XUL 	nsPrintEngine::DoCommonPrint 	layout/printing/nsPrintEngine.cpp:589
25 	XUL 	nsPrintEngine::CommonPrint 	layout/printing/nsPrintEngine.cpp:418
26 	XUL 	nsPrintEngine::Print 	layout/printing/nsPrintEngine.cpp:724
27 	XUL 	DocumentViewerImpl::Print 	layout/base/nsDocumentViewer.cpp:3583
28 	XUL 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_unixish_x86.cpp:179
29 	XUL 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2422
30 	XUL 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1477
31 	libmozjs.dylib 	js_Invoke 	js/src/jsinvoke.cpp:1313
...
...

If it crashes on a different printer, please post a crash ID for that one as well.
Severity: major → critical
Summary: Firefox crashes if the second time I try to print in a session → Firefox crashes if the second time I try to print in a session [@ libobjc.A.dylib@0x15688 - CanonIJPDE ]

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460963

Updated

10 years ago
Status: RESOLVED → VERIFIED

Comment 3

10 years ago
Do you have KeyCue installed at all, or anything else bound to the Command key ?
(Reporter)

Comment 4

10 years ago
No, the only things that are bound to the command key are keyboard shortcuts in the applications themselves (i.e. command-p for print, command-c for copy).  For the record, firefox crashes regardless of how I open the print dialogue, be it with command-p or by selecting print from the file menu.
You need to log in before you can comment on or make changes to this bug.