Closed Bug 460963 Opened 13 years ago Closed 10 years ago

Canon printer driver crashing on print in MacOSX [@ libobjc.A.dylib@0x15688 - CanonIJPDE ]

Categories

(Core :: Printing: Output, defect)

1.9.0 Branch
All
macOS
defect
Not set
critical

Tracking

()

RESOLVED INVALID

People

(Reporter: strawberrymaggie, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [needs debugging help from Canon])

Crash Data

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3

web browsing in Firefox 3.0.3 is fine until either use keyboard command or File Print to print page - then firefox crashes.       

Also sometimes Print and Page Setup from file menu are greyed out and unusable.           

Reproducible: Always

Steps to Reproduce:
1. Tried new tabs, new windows, different websites, using preview prior to printing
2.
3.
Actual Results:  
still happening


When firefox crashes you can then restart and are given the option to open previous session or start new session.     If the page you were on was hppts you can not resume session and have to begin again.      I've started using a different web browser as I don't have time for all the restarts.
Run Firefox in safe mode: http://support.mozilla.com/en-US/kb/Safe+Mode
and then try again and see if it crashes.
The safemode is part of the "get a stacktrace" instructions.
Remove Reports
Submitted Crash Reports


  

    
      
        Report ID
        	Date Submitted
      

    
    
    8ff7695e-9f6e-11dd-981a-001a4bd43ef6	21/10/08	13:48
8678a523-9de7-11dd-bc14-001cc45a2ce4	19/10/08	15:09
5752a735-9ddd-11dd-86f4-001cc4e2bf68	19/10/08	13:56
207a8902-9ddd-11dd-b717-001321b13766	19/10/08	13:54
6ac45cfd-9dcb-11dd-8a6f-001321b13766	19/10/08	11:48
c66f2561-9dbb-11dd-bb44-0013211cbf8a	19/10/08	09:56
15545f23-9a03-11dd-b3e7-001a4bd43e5c	14/10/08	16:16
d8dca6d9-99fa-11dd-9a6d-001a4bd43e5c	14/10/08	15:17
bdfd825c-95e9-11dd-be73-001a4bd43ed6	9/10/08	11:05
7613b9eb-95e9-11dd-a71d-001321b13766	9/10/08	11:03
45d34b19-958a-11dd-b753-001a4bd43ed6	8/10/08	23:41
c5efd7e8-91f5-11dd-b97d-001a4bd43e5c	4/10/08	10:21
adb0b00f-9166-11dd-a1b1-001a4bd43ed6	3/10/08	17:16
08bd2c0a-913e-11dd-a2ff-0013211cbf8a	3/10/08	12:25
6bf8e978-90b0-11dd-b96e-001321b13766	2/10/08	19:32
7da802d7-8eff-11dd-bef8-001321b13766	30/9/08	15:53
c6c41763-8efe-11dd-ba6c-001cc4e2bf68	30/9/08	15:48
89ef2957-8efd-11dd-a606-001cc4e2bf68	30/9/08	15:39
9ed21385-8efa-11dd-b7bc-001a4bd43e5c	30/9/08	15:18
b655f675-8ef5-11dd-8810-001cc45a2ce4	30/9/08	14:43
ae582994-8ee6-11dd-a17a-001321b13766	30/9/08	12:55
26019a7d-8e45-11dd-a63b-001cc45a2c28	29/9/08	17:39
51035914-8e0d-11dd-a60b-001a4bd43ed6	29/9/08	10:59
2c5548b5-8c89-11dd-b6fb-001cc45a2c28	27/9/08	12:41
68f78bde-4e8d-11dd-9d36-001321b13766	10/7/08	15:35

  


No crash reports have been submitted.

This application has not been configured to display crash reports. The preference breakpad.reportURL must be set.
It looks like your canon printing driver is crashing :-(

0  	libobjc.A.dylib  	libobjc.A.dylib@0x15688  	
1 	CanonIJPDE 	CanonIJPDE@0x14111 	
2 	CanonIJPDE 	CanonIJPDE@0x141d4 	
3 	CanonIJPDE 	CanonIJPDE@0x15df3 	
4 	CanonIJPDE 	CanonIJPDE@0x15d2c 	
5 	Foundation 	Foundation@0xa2db 	
6 	CoreFoundation 	CoreFoundation@0x53ab9 	
7 	CoreFoundation 	CoreFoundation@0x53d92 	
8 	Foundation 	Foundation@0x743f 	
9 	Foundation 	Foundation@0x10c87 	
10 	CanonIJPDE 	CanonIJPDE@0x158fa 	
11 	CanonIJPDE 	CanonIJPDE@0x6eb8 	
12 	CanonIJPDE 	CanonIJPDE@0x130a 	
13 	PrintCocoaUI 	PrintCocoaUI@0x63e2 	
14 	PrintCocoaUI 	PrintCocoaUI@0x4ae9 	
15 	PrintCocoaUI 	PrintCocoaUI@0x31a5 	
16 	PrintCocoaUI 	PrintCocoaUI@0x18797 	
17 	PrintCocoaUI 	PrintCocoaUI@0x22798 	
18 	AppKit 	AppKit@0xa8275 	
19 	AppKit 	AppKit@0x4635d 	
20 	PrintCocoaUI 	PrintCocoaUI@0x1db08 	
21 	PrintCocoaUI 	PrintCocoaUI@0xd5cf 	
22 	Print 	sessionPrintDialog 	
23 	XUL 	nsPrintingPromptService::ShowPrintDialog 	mozilla/embedding/components/printingui/src/mac/nsPrintingPromptServiceX.mm:348
24 	XUL 	nsPrintEngine::DoCommonPrint 	mozilla/layout/printing/nsPrintEngine.cpp:589
25 	XUL 	nsPrintEngine::CommonPrint 	mozilla/layout/printing/nsPrintEngine.cpp:418
26 	XUL 	nsPrintEngine::Print 	mozilla/layout/printing/nsPrintEngine.cpp:724
27 	XUL 	DocumentViewerImpl::Print 	mozilla/layout/base/nsDocumentViewer.cpp:3489
Component: General → Printing: Output
Product: Firefox → Core
QA Contact: general → printing
Duplicate of this bug: 470981
Hardware: PowerPC → All
Summary: firefox 3.0.3 crashes when I try to print webpage regardless of website. → Cannon printer driver crashing on print in MacOSX [@ libobjc.A.dylib@0x15688 - CanonIJPDE ]
Version: unspecified → 1.9.0 Branch
Which printer are you using ?
I will try to contact someone at Canon.
bug 470981 mentions a Canon Pixma MP610
Contacted Canon USA via Web-Form
Assignee: nobody → giles.puckett
Keywords: crash
Still have same problem.  Now using Firefox 3.0.5.

Printer Canon IP4500 Pixma.
Strawberry
The cannon support suggested that you upgrade to the latest printer driver fro their homepage :

=========================================================================
1.  Visit Canon's web site at:  www.canontechsupport.com
2.  On the Consumer Products Home Support page, below the "Please choose
the model from the dropdown menus below:", select your model in the 
following manner: 
     a.  From the top dropdown box, click on the down arrow and select 
Multifunction.
     b.  From the middle dropdown box, click on the down arrow and 
select Inkjet as the product type.
     c.  From the bottom dropdown box, click on the down arrow and 
select your model then click GO.
3.  On the Support page for your model, click the Drivers & Downloads 
tab.
4.  Select your operating system from the "Select OS" dropdown box.
5.  Scroll down the page and you will find all downloads available for 
your model and the selected operating system.  Click the link for the 
file you want to download.
6.  Instructions for completing the download and installation will 
appear on the page that follows.  You will also see a Disclaimer at the 
bottom.  Review the disclaimer and click I Agree - Begin Download.
========================================================================

It would be nice if you try it. If you still crash I will try to get a real developer at this issue.
The driver update seems to have worked.  Download the first driver listed (Mac OS X CUPS), open the print dialogue (apple-p), from the drop down printer menu, select add printer, click on the Canon MP610 series, and wait for it to load the settings.
Then go to the drop down Print Using: menu and select Canon IJ Printer, click add and confirm that you want to add the same printer again.

It should be fixed now (it was for me) if not, I would recommend switching which printer is default by selecting Print & Fax Preferences from the Printer selection menu in the print dialogue.

Thanks a lot for all your work on this Matthias!
strawberrymaggie: Does the driver update fix it for you too?
Oh, I thought that https://bugzilla.mozilla.org/show_bug.cgi?id=348605 was the same as this one. Perhaps it is different after all.

I'm using Firefox 3.0.5, OS X 10.5.6 on a Mac Pro and I'm using the MP610, too. The driver version is one on the website right now, 10.1.2.0, so the driver update does NOT fix this. In fact, I just got the printer, and this was the only driver for this printer ever installed.

Here is an example of a typical crash log:
http://crash-stats.mozilla.com/report/index/f0fadd81-f4f5-4d84-8569-25a912081225?p=1
I'd advise trying the other print driver then.  It gave me two, I did install both although I thought that it was the CUPS one that made it work in the end.  However, it is quite possible that it was the other.  I'd probably submit a report to canon if you can't get it to work, since it does seem to be crashing in their drivers.  Good luck.
Please ask the canon support and tell them that you have the latest driver and point them to this bug.

the stack trace from comment #14 is the same crash in the driver.
I will ask them again if you fail to get an answer.
Duplicate of this bug: 474256
Sorry, forgot to mention the other, second, driver (6.9.3) works. I'm not sure what the difference is between them other than first one crashes and the second one does not. (I'm not sure why the first driver is referenced as CUPS. If I understand correctly, all printing in OS X is managed through CUPS.)
Duplicate of this bug: 483091
Duplicate of this bug: 493655
Duplicate of this bug: 486265
I am using a Canon MP970 with Firefox 3.0.11 and Mac OSX 10.5.6.  I have had this problem for quite some time.  I was able to resolve by using the other driver on the Canon support site for this printer.  Nice to have FF working again.  thanks for the info.
I called canon today and gave them this bug number and some information. hopefully this report will be sent to an engineer.

OK, using Frank L's printer model, I reached:
http://www.usa.canon.com/consumer/controller?act=ModelInfoAct&tabact=DownloadDetailTabAct&fcategoryid=334&modelid=15481

And in:
Please select your operating system to view available drivers and software.

I selected "Mac OS X" at which point, it had a table, which I'm trimming to show the relevant bits

Date Posted	Version/Description	File Name
08/27/2008	10.1.2.0 (OS X CUPS)	mp970sosxcp10120ej7.dmg
03/25/2008	6.9.3 (OS X)		mp970sosxpd693ej7.dmg
11/28/2007	13.9.0 (Scanner Driver)	mp970sosxsd1390ej7.dmg

Frank L: I take it that you're saying the 8/27 drivers cause crashes but the 3/25 drivers work?
Summary: Cannon printer driver crashing on print in MacOSX [@ libobjc.A.dylib@0x15688 - CanonIJPDE ] → Canon printer driver crashing on print in MacOSX [@ libobjc.A.dylib@0x15688 - CanonIJPDE ]
Assignee: giles.puckett → nobody
Yes that is correct.  I was successful when I used the 6.9.3 driver.  10.1.2.0 CUPS causes FF crash after second print.
I have this same problem (FF crashes every other time I try to print) and I haven't found any solution. In the Canon website there is only one driver for my brand new mp450, dated 11/08/2007. I believe it's the same as I have now. I hope someone could fix this, it's really annoying...
Sorry for misinformation: my Canon is mp540, not mp450. There are no drivers for this one at Canon website...??
Lariza: try drivers from here for the mp540: http://software.canon-europe.com/products/0010641.asp
You can narrow it by operating system (presumably OS X) and language (I think they only have English, but I don't think printer drivers would be language specific).
I believe that the driver you want would be "Printer Driver for Mac OSX (7.11.0)", but if that doesn't work, you can try " CUPS Printer Driver for OSX (10.10.1.0)".
I think the reason you didn't see drivers might be that I think this is a non-US printer, just so you know.  If anyone else has similar problems, you can try googling canon <your printer model> driver.
Thanks for the tip! I had a little bit weird installation process: after I installed the 7.11.0, my mac couldn't find any printer anymore (a bit worrying!). Then I installed the second one (CUPS). Now it finds the printer, happily, but when I check the preferences, the driver it's using is the 7.11.0, not the CUPS one. Well, I'm happy it works now anyway, thanks for the help! :)
Duplicated with the Canon MP610 using the 10.1.2 CPS dirver. Using the IJ 6.9.3 driver seems to correct the problem.
Using the very latest drivers for my Canon iP4500. Still happens, has plagued me for months and months...crashes every other time I try to print in FF. This is consistent and reproducible. Specs: Mac Pro, 1xQuad Xeon, 10GB RAM, Leopard, FF 3.5.
Guys, PLEASE complain by phone to canon (1-800-OK-CANON).

The ball is in their court, and right now all you're doing is turning this bug into a mess, which will hurt anyone's ability to read/fix it (including the engineer from Canon, who will eventually read this bug and hopefully be the one to actually research and fix their driver).

If you want support from us, please use http://support.mozilla.com instead (note that all we can do is walk you through their web site to either their other printer driver or to the phone number so you can call them).

As you need to CALL canon, their number is: 1-800-652-2666 (1-800-OK-CANON), please CALL them, provide all the details and provide this bug's url. Note that in certain commercial systems the more phone calls complaining about a problem, the sooner it's researched.

In our system, this is not the case, we fix bugs we can fix, and this isn't a bug we can fix, so adding comments just annoys us.
Whiteboard: [needs debugging help from Canon]
"...In our system, this is not the case, we fix bugs we can fix, and this isn't a
bug we can fix, so adding comments just annoys us..."

Well sorry it annoys you but how come printing on my Canon 4500 worked fine before FF 3.x.x and now it doesn't. I haven't changed any Canon drivers -  it's a Mozilla problem - stop dodging the issue and fix it please!
Terry: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Their printer driver is crashing. The end. Just because it's triggered by Firefox doesn't mean anyone here has control over it. Just because there may be something in Firefox it doesn't handle well does not make it Firefox's fault. Do you honestly think we'd pretend we couldn't fix a crash?

There is no magic "fix it" wand.
Dave: "Their driver" - this affects a number of diferent Canon printers and drivers. Check the forums. If FF2.x.x worked and FF 3.x.x doesn't then surely it's a backwards compatibility issue for FF. I haven't changed my Canon drivers from installation day and which worked fine on FF2. 

I have emailed Canon with all details with links to this bug report and the forums. Hopefully someone there might help us.
(In reply to comment #34)
> Dave: "Their driver" - this affects a number of diferent Canon printers and
> drivers.

So? That would just mean that whatever is crashing is shared code among their drivers for different models.

> If FF2.x.x worked and FF 3.x.x doesn't then surely
> it's a backwards compatibility issue for FF.

If true, what you're saying is that their driver can't handle newer Firefox, not the other way around. On no planet is a crash within the driver (and it is, if you can read comment 5) not a problem within the driver. For the last time, just because Firefox is tripping over their land mine does not mean that Firefox is the cause. At most, if we're lucky, a work-around could be made in Firefox, and that is not a fix, just a band-aid. Furthermore, even if there is an underlying problem in Firefox here (in addition to whatever is crashing on their end) there's no way anyone here can debug someone else's software to find it. And EVEN IF all of the above was some sort of evil conspiracy, no amount of complaining is going to change it.

> I have emailed Canon with all details with links to this bug report and the
> forums. Hopefully someone there might help us.

That is the hope.

By the way, just to clarify, you're getting this in the current version of Firefox 3.5.2? (all the others above were just on 3.0.x)
I'm no techie,but I do not see why Canon, Apple and Firefox wouldn't all be trying to solve this, especially as the printer that crashes for me a Canon MP480 came with my new IMAC which I purchased in April 2009. April fools Day, in fact. Should have known better
Firefox 3.5.2. Crashes on every 3.x.x

Thanks for your help............
Terry: Thanks.

Paula and everyone else: Yeah, Canon should be working to solve this. See comment 31.

To anyone just reading this and not the rest of the bug: Some people resolved their problems with a driver upgrade. See comment 11 & 12. Others, apparently, did not.

As has been said many times before, louder is not necessarily better. Additional "I get it too" comments are quite useless in most cases. Please, I know this is frustrating, but this is not the place to vent. Only post here if you have something new to add such as a version number that fixes something or a new reply from Canon.

For Mozilla support, go here:
http://support.mozilla.com

Please let this be the last comment here for a while. We don't need any more clutter here.
@ Dave
First response from Canon - not very promising ref not being able to comment on third party developer's comments. I'll post back with any developments.

Thanks
========================

I am sorry to hear that you are having problems with your canon product.
 
With reference to your enquiry, I will pass on your comments to the relevant department.  I must advise that we are unable to comment on forum comments or comments by third party developers.  As you state yourself, the printer worked prior to the upgrade.
 
I hope this information is of use to you. If you have any other queries, or need any other information, please do not hesitate to reply directly to this email, and quoting the reference number:-  364857
Duplicate of this bug: 441350
This appears to be fixed!!!  At least for me and my GF.  
Mozilla version 3.5.2 
OS X version 10.5.8 


I doubt it is a printer driver problem, as stated in the dell printer sister bug of this one, it happened with three different printers, and even happened with a fresh install of OS X (no printer drivers) printing to pdf.

Either Firefox or Apple has fixed this for me.  If everyone else could post their results I would appreciate it.  Hopefully it's not just a fix on our Macs.
On friday we got about 
565 total crashes for  the signature libobjc.A.dylib@0x15688 
64 of these were start up crashes inside 3 minutes

signature list
 177 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e
  98 libobjc.A.dylib@0x15688 | IdleTimerVector
  68 libobjc.A.dylib@0x15688 | HPSmartPrint@0xe1ef
  47 libobjc.A.dylib@0x15688 | imgRequestProxy::OnStopFrame(gfxIImageFrame*)
  24 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14cee
  19 libobjc.A.dylib@0x15688 | -[ToolbarWindow sendEvent:]
  18 libobjc.A.dylib@0x15688 | _nsnote_callback
  12 libobjc.A.dylib@0x15688 | getContext_ADCM
  11 libobjc.A.dylib@0x15688 | nsPluginInstanceOwner::Notify(nsITimer*)
  10 libobjc.A.dylib@0x15688 | HIToolbox@0x9e57b
   6 libobjc.A.dylib@0x15688 | LLCStyleInfoCreateActiveStyleInfo
   5 libobjc.A.dylib@0x15688 | CanonIJPDE@0x15cce
   4 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14111


os breakdown for the Canon related crashes...

  82 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Mac OS X 10.5.7 9J61
  39 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Mac OS X 10.5.8 9L30
  25 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Mac OS X 10.5.8 9L31a
  12 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Mac OS X 10.5.7 9J3050
  12 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Mac OS X 10.5.6 9G55
   9 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14cee Mac OS X 10.5.7 9J61
   8 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14cee Mac OS X 10.5.8 9L30
   7 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14cee Mac OS X 10.5.8 9L31a
   3 libobjc.A.dylib@0x15688 | CanonIJPDE@0x15cce Mac OS X 10.5.8 9L31a
   3 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Mac OS X 10.5.6 9G3610
   2 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Mac OS X 10.5.7 9J3032
   1 libobjc.A.dylib@0x15688 | CanonIJPDE@0x15cce Mac OS X 10.5.8 9L30
   1 libobjc.A.dylib@0x15688 | CanonIJPDE@0x15cce Mac OS X 10.5.7 9J61
   1 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Mac OS X 10.5.6 9G2133
   1 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Mac OS X 10.5.6 9G2030


   3 libobjc.A.dylib@0x15688 | -[ToolbarWindow sendEvent:] Mac OS X 10.5.6 9G55


  41 libobjc.A.dylib@0x15688 | IdleTimerVector Mac OS X 10.5.7 9J61
  35 libobjc.A.dylib@0x15688 | IdleTimerVector Mac OS X 10.5.8 9L30
  35 libobjc.A.dylib@0x15688 | HPSmartPrint@0xe1ef Mac OS X 10.5.7 9J61
  26 libobjc.A.dylib@0x15688 | imgRequestProxy::OnStopFrame(gfxIImageFrame*) Mac OS X 10.5.7 9J61
  22 libobjc.A.dylib@0x15688 | HPSmartPrint@0xe1ef Mac OS X 10.5.8 9L30
  17 libobjc.A.dylib@0x15688 | IdleTimerVector Mac OS X 10.5.8 9L31a
  13 libobjc.A.dylib@0x15688 | imgRequestProxy::OnStopFrame(gfxIImageFrame*) Mac OS X 10.5.8 9L30
  11 libobjc.A.dylib@0x15688 | _nsnote_callback Mac OS X 10.5.7 9J61
   9 libobjc.A.dylib@0x15688 | HIToolbox@0x9e57b Mac OS X 10.5.7 9J3050
   9 libobjc.A.dylib@0x15688 | -[ToolbarWindow sendEvent:] Mac OS X 10.5.7 9J61
   8 libobjc.A.dylib@0x15688 | HPSmartPrint@0xe1ef Mac OS X 10.5.8 9L31a
   7 libobjc.A.dylib@0x15688 | nsPluginInstanceOwner::Notify(nsITimer*) Mac OS X 10.5.7 9J61
  6 libobjc.A.dylib@0x15688 | getContext_ADCM Mac OS X 10.5.7 9J61
   6 libobjc.A.dylib@0x15688 | _nsnote_callback Mac OS X 10.5.8 9L30
   6 libobjc.A.dylib@0x15688 | -[ToolbarWindow sendEvent:] Mac OS X 10.5.8 9L30
   5 libobjc.A.dylib@0x15688 | IdleTimerVector Mac OS X 10.5.6 9G55
   4 libobjc.A.dylib@0x15688 | imgRequestProxy::OnStopFrame(gfxIImageFrame*) Mac OS X 10.5.8 9L31a
   4 libobjc.A.dylib@0x15688 | getContext_ADCM Mac OS X 10.5.8 9L30
   4 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14111 Mac OS X 10.5.7 9J61
   3 libobjc.A.dylib@0x15688 | nsPluginInstanceOwner::Notify(nsITimer*) Mac OS X 10.5.8 9L30
   3 libobjc.A.dylib@0x15688 | imgRequestProxy::OnStopFrame(gfxIImageFrame*) Mac OS X 10.5.7 9J3050
   3 libobjc.A.dylib@0x15688 | -[NSConcreteMapTable rehashAround:] Mac OS X 10.5.7 9J61
   2 libobjc.A.dylib@0x15688 | nsNPAPIPluginStreamListener::OnDataAvailable(nsIPluginStreamInfo*, nsIInputStream*, unsigned int) Mac OS X 10.5.7 9J61
   2 libobjc.A.dylib@0x15688 | libawt.jnilib@0x1cc5 Mac OS X 10.5.8 9L30
distribution of versions where the crash was found on 20090821-crashdata.csv
 359 Firefox 3.5.2
 104 Firefox 3.0.13
  19 Firefox 3.0.10
  14 Firefox 3.0.11
  13 Firefox 3.5
  11 Firefox 3.5.1
  10 Firefox 3.0.12
   8 Firefox 3.0.8
   7 Firefox 3.0.3
   6 Firefox 3.0.6
   4 Firefox 3.0.5
   3 Firefox 3.0.4
   3 Firefox 3.0.1
   2 Firefox 3.0
   1 Firefox 3.5b4
   1 Firefox 3.0.7
combinations of firefox versions and os versions where the crash was seen on friday

  40 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.5.2 Mac OS X 10.5.7 9J61
  31 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.5.2 Mac OS X 10.5.8 9L30
  23 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.0.13 Mac OS X 10.5.7 9J61
  19 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.5.2 Mac OS X 10.5.8 9L31a
   9 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.5.2 Mac OS X 10.5.7 9J3050
   8 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14cee Firefox 3.5.2 Mac OS X 10.5.8 9L30
   6 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14cee Firefox 3.5.2 Mac OS X 10.5.7 9J61
   5 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.5.2 Mac OS X 10.5.6 9G55
   5 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.0.13 Mac OS X 10.5.6 9G55
   5 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.0.10 Mac OS X 10.5.7 9J61
   4 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.0.13 Mac OS X 10.5.8 9L31a
   4 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14cee Firefox 3.5.2 Mac OS X 10.5.8 9L31a
   3 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.5.2 Mac OS X 10.5.6 9G3610
   3 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.5.1 Mac OS X 10.5.7 9J61
   3 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.5 Mac OS X 10.5.7 9J61
   3 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.0.11 Mac OS X 10.5.7 9J61
   3 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14111 Firefox 3.5.2 Mac OS X 10.5.7 9J61
   2 libobjc.A.dylib@0x15688 | CanonIJPDE@0x15cce Firefox 3.0.10 Mac OS X 10.5.8 9L31a
   2 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.5.1 Mac OS X 10.5.8 9L31a
   2 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.5.1 Mac OS X 10.5.8 9L30
   2 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.0.8 Mac OS X 10.5.7 9J61
   2 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.0.3 Mac OS X 10.5.8 9L30
   2 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.0.13 Mac OS X 10.5.8 9L30
   2 libobjc.A.dylib@0x15688 | CanonIJPDE@0x1531e Firefox 3.0.11 Mac OS X 10.5.8 9L30
   2 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14cee Firefox 3.0.13 Mac OS X 10.5.8 9L31a
   2 libobjc.A.dylib@0x15688 | CanonIJPDE@0x14cee Firefox 3.0.13 Mac OS X 10.5.7 9J61
Not fixed on my CAnon IP4500/FF 3.any version. I'm still waiting for a response from Canon as Mozilla are not going to do anything. (See post 39)
I'm still having the same problem, with different Canon printers - in my case both a Pixma Pro 9000 (by USB) and an MX850 (by network). So are a lot of other people (see the forum postings on http://forums.mozillazine.org/viewtopic.php?f=38&t=846285&start=30)
http://forums.mozillazine.org/viewtopic.php?p=7245835#p7245835 is an interesting bit of information from Canon Tech Support.
(In reply to comment #47)
> http://forums.mozillazine.org/viewtopic.php?p=7245835#p7245835 is an
> interesting bit of information from Canon Tech Support.

However, this didn't fix the problem for me. Furthermore, the equivalent problem doesn't happen on Safari.
Upgraded to Snow Leopard + 10.6.1 update. Problem fixed. (Canon IP4500 FF 3.5.3)
(In reply to comment #49)
> Upgraded to Snow Leopard + 10.6.1 update. Problem fixed. (Canon IP4500 FF
> 3.5.3)

and in several postings since this, some people have resolved this by installing new canon drivers, or updating firefox
http://forums.mozillazine.org/viewtopic.php?p=8294625#p8294625
http://forums.mozillazine.org/viewtopic.php?p=8240485#p8240485
http://forums.mozillazine.org/viewtopic.php?p=8243985#p8243985

those who updated firefox and are now working may have picked up fixes
Bug 396680 - [10.5] Crash on attempt to print to unreachable HP printer [@ objc_msgSend - HPSmartPrint@0xe4cc]

xref for users of trunk builds Bug 520494 - Implement the Cocoa print dialog in a way that works on 10.4 

=> invalid
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Duplicate of this bug: 534473
Duplicate of this bug: 348605
Crash Signature: [@ libobjc.A.dylib@0x15688 - CanonIJPDE ]
Purchased new MG3500 as a replacement for the E12 4100 with the crash problem and no drive updates planned.  Problems seems to have intensified with new printer.  New Canon ColorQube MG3500 will not print more then four pages before it prints half a page and stops with an error "early eof reading control byte". I also try to http://printertechsupportnumbers.com/blog/how-to-fix-canon-printer-offline-error/
You need to log in before you can comment on or make changes to this bug.