Back function sometimes does nothing

VERIFIED DUPLICATE of bug 32444

Status

()

Core
Document Navigation
P3
normal
VERIFIED DUPLICATE of bug 32444
18 years ago
9 years ago

People

(Reporter: David M. Karr, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20000731
BuildID:    2000073120

While navigating through the JDK API doc tree, it's very important for
navigation to be convenient and "logical".  The behavior of the "Back" function
is relevant to this.

In "Steps to Reproduce", I describe in detail the following scenario:

1. Select a class from the "All Classes" frame.
2. Page down to the start of the method summaries.
3. Click on the link for the first method.
4. In the method detail, click on a link for another class.
5. Press Back.  In 4.73, it goes right back to where it was.  In Mozilla,
nothing happens.  The Back button was sensitive, but nothing happened when I
pressed it.

Reproducible: Always
Steps to Reproduce:
1. Visit http://java.sun.com/j2se/1.3/docs/api/index.html
2. Click on "AbstractAction" in "All Classes" frame.
3. Click below the vertical scrollbar thumb to go down one page, so that the
first method in the "Method Summary" is shown.
4. Click on the link for the detail for the "addPropertyChangeListener()" method.
5. In the "Specified by" section of this method detail, click on the link for
the "Action" class.
6. The "Action" class is viewed, the Back button is sensitive.  Now click on the
Back button.

Actual Results:  The button clicks, but nothing happens.  It doesn't go back to
viewing the "addPropertyChangeListener()" method of "AbstractAction".

Expected Results:  It should have returned the main content frame to view the
"addPropertyChangeListener()" method of the "AbstractAction" class.

Comment 1

18 years ago
I experienced the same - following the described steps made my back-button to be
disabled ! Presing "Alt+Cursor-Back" made the back-button to be enabled again,
but nothing happends while clicking on it, the back-history though has several
entries.

Updated

18 years ago
Assignee: asa → radha
Component: Browser-General → History
QA Contact: doronr → claudius

Comment 2

18 years ago
->history, leaving to claudius the wonderful job of determining if this is a 
dup of all the 'back doesn't work!' bugs :P

Comment 3

18 years ago
Also disables the back button on linux 3009. Confirming and changing OS to all.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Blocks: 47238

Comment 4

18 years ago
I think this is just a dup of bug 32444, since when I pulled the page out of 
the frameset, it worked fine.  Please be sure to double-check this once that's 
fixed, however.

*** This bug has been marked as a duplicate of 32444 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.