Closed Bug 471865 Opened 11 years ago Closed 11 years ago

Bookmark properties dialog mispositioned

Categories

(Firefox :: Theme, defect, trivial)

All
macOS
defect
Not set
trivial

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: wesj, Assigned: mstange)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081230 Firefox/3.1b1pre (.NET CLR 3.5.30729)
Build Identifier: 

The bookmark properties dialog is positioned to far to the left on OSX.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Attached image Screenshot of problem
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
a regression range would be cool
Bug 279539 is in the range...
Yeah, bug 279539 seems very likely. In bug 462650 I used margin-right to position #editBookmarkPanel because margin-left didn't work - maybe that's fixed now?
this sounds quite visible, asking blocking to put this on drivers' radar, even if from a functionality point of view it will not block anything.
Flags: blocking-firefox3.1?
Yes, I run into that problem while testing the tryserver build on bug 413053.
Attached patch fixSplinter Review
Enn, is this the right fix?
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #355824 - Flags: review?(enndeakin)
Is 27 pixels the distance between the arrow point and the star icon?
It's the distance between the right edge of the star icon and the right edge of the panel shadow (when the panel is at the intended position).

That is, the panel's right edge is 27px right of the star icon.
It's the distance between the right edge of the star icon and the right edge of the panel shadow (when the panel is at the intended position).

That is, the panel's right edge is 27px right of the star icon.
Comment on attachment 355824 [details] [diff] [review]
fix

OK, I think that's what I meant to ask.
Attachment #355824 - Flags: review?(enndeakin) → review+
Removing the blocking request - Bug 279539 hasn't landed on 1.9.1 yet, so this bug probably doesn't even exist in 3.1.
Flags: blocking-firefox3.1?
http://hg.mozilla.org/mozilla-central/rev/82a898e520fe
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.2a1
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090118 Minefield/3.2a1pre ID:20090118020617
Status: RESOLVED → VERIFIED
Hardware: x86 → All
OS: Mac OS X → All
OS: All → Mac OS X
You need to log in before you can comment on or make changes to this bug.