Closed Bug 471937 Opened 13 years ago Closed 10 years ago

Need options to control compacting folders

Categories

(Thunderbird :: Preferences, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 439089

People

(Reporter: tim, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: version 2.0.0.19 (20081209)

Currently, Thunderbird compacts folders at various times while I am reading/creating/deleting emails.  There seems to be no way to control this other than the one entry under |Tools|Options|Network & Disk Space| to "Compact folders when it will save over ___ kb".  

Meanwhile, every time it compacts folders, it appears to confuse the indexing.  Most common, if it compacts folders while I'm reading a message, Thunderbird forgets what message I was on.  If I try to delete that message, the delete operation fails.  If I quit the message, Thunderbird no longer knows which message it was: no message is highlighted, and the message I was reading may be marked as unread.  

(I've written about this problem before, but I'd like to suggest a partial solution here.)

My suggestion is that the "Disk Space" section under |Tools|Options|Network & Disk Space| be expanded with options that totally control when compacting occurs.  The option I'd most like to see added is one to do compacting ONLY when shutting down the session.  Another option could allow compacting ONLY when no messages are open and no other activity has occurred for 1 minute.  3rd, I'd suggest changing the behavior of the current option so that it would always have to ask the user if it's okay to do compacting now.  If the user does not respond within one minute, then it could default to 'yes'. 

I doubt any one of those options would please everyone.  But between the three of them, I expect everyone would like at least one better than what is happening now.



Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird
2. Read & delete one message.
2a. (Compacting often happens while you're reading the 2nd one.)
3. Continue working in Thunderbird for an extended time.
3a. (Compacting reoccurs at seemingly random times.)
Actual Results:  
Thunderbird forgets its indexing, you cannot delete your current message, and when you quit the message Thunderbird doesn't tell you where in the message list you were.

Expected Results:  
Compacting should never happen while I'm working with messages unless I tell it to, or else its indexing needs to be robust enough to remember everything else that's going on WHILE it's compacting the folders.
Version: unspecified → 2.0
Severity: normal → enhancement
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: DUPEME
Version: 2.0 → Trunk
Yep, this happens to me from time to time to in TB 3. You just have to wait for it to finish indexing and then do what you were trying to do.
any aspects beyond comment 2 should be solved via bug 439089
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 439089
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.