Thunderbird unusable after removing a couple of accounts

RESOLVED DUPLICATE of bug 469448

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 469448
9 years ago
9 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({perf, regression})

Trunk
x86
Mac OS X
perf, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090104 Shredder/3.0b2pre

Currently I try to create a testcase for bug 469448. The first step I did was to remove all unnecessary accounts, so the one broken POP3 account will remain. After closing the account wizard Thunderbird does react more than unbelievable slow to my actions. All the time the litte clock cursor is shown. Repainting the UI is even slow and it takes up to 2s when switching spaces.

Now half an hour later there is no change at all. I'll try to fetch some useful information and upload them step by step.

Hopefully I can also supply a testcase.
Flags: blocking-thunderbird3?
(Reporter)

Comment 1

9 years ago
Created attachment 355328 [details]
Samples from Activity monitor

This is a result from sampling with the Activity Monitor while Shredder is in this undefined state.
(Reporter)

Comment 2

9 years ago
Created attachment 355330 [details]
Open files

This is a list of the opened files.
(Reporter)

Comment 3

9 years ago
I believe this depends on bug 469448. Will try to reproduce in a second.
Depends on: 469448
(Reporter)

Comment 4

9 years ago
The assumption was correct. With the perf issue in bug 469448 fixed the account deletion works like a charm. No hang anymore.
Keywords: regressionwindow-wanted
Accepting blocking, but note that it's likely fixed when the the dependent bug is fixed.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
(In reply to comment #4)
> The assumption was correct. With the perf issue in bug 469448 fixed the account
> deletion works like a charm. No hang anymore.

How did you fix the perf issue in that bug, btw, Whimboo?

Comment 7

9 years ago
I believe he clicked on the folders to make the .msf files valid, so we wouldn't try to open the db over and over and over again...
(Reporter)

Comment 8

9 years ago
Yes, it was a hassle to click on all the >100 folders but finally I wasn't affected by this bug anymore.
Actually, since we're certain it's a duplicate of bug 469448, let's just mark it as one.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
No longer depends on: 469448
Flags: blocking-thunderbird3+
Resolution: --- → DUPLICATE
Duplicate of bug: 469448
You need to log in before you can comment on or make changes to this bug.