Thunderbird does not clear selected attachment when switching to another email

RESOLVED DUPLICATE of bug 317699

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 317699
10 years ago
10 years ago

People

(Reporter: Not interested in Mozilla any more, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: version 2.0.0.19 (20081209)

When you click on an attachment in an email and then click on another email that also has attachments Thunderbird still thinks you have the attachment in the first email selected. The context menu for the second email works against the first email.

Reproducible: Always

Steps to Reproduce:
1. Select an email (email1) that has an attachment.
2. Click on the attachment in the panel to select it.
3. Click on a second email (email2) that also has attachments, but do not click on an attachment.
4. Right click on the attachment panel (but not on an attachment).
Actual Results:  
You get a context menu for the attachment in the first email (email1). You can see that we have 'Open' and 'Save as' etc enabled, even though you do not have an attachment in the current email (email2) selected.

If you select 'Save as' from the context menu you get a save dialog for the attachment in the first email (email1).

Expected Results:  
Clicking on a new email in the list should clear the attachment selection giving you no selected attachments. This would give you the correct context menu offering 'Save all', 'Detach all' etc.

Comment 1

10 years ago
wow.  happens on trunk too. 

Did you search to see if this bug is already reported?
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader
(Reporter)

Comment 2

10 years ago
I did look but I didn't find anything.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 317699
You need to log in before you can comment on or make changes to this bug.