mochitest-browser-chrome favicon load occasionally leaks

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

(Blocks: 1 bug, {intermittent-failure, memory-leak})

Trunk
x86
Windows 2000
intermittent-failure, memory-leak
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qaw: reproducible?] [See comment 10] )

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090108 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/37ac7732142f)

While investigating bug 465952, I noticed that running browser_alltabslistener.js alone often leaks 5 to 8 KB.

I use
python runtests.py --browser-chrome --test-path=browser/base/content/test --leak-threshold=0 --autorun --close-when-done
with only alltabslistener.html and browser_alltabslistener.js.

It looks like running tests 1 to 3 never leaks;
but trying to add test 4 or 5 triggers the leak.


NB: I wonder if this leak could be causing the increased bug 465952 leak...
Flags: wanted-firefox3.1?
(Reporter)

Comment 1

10 years ago
Created attachment 355980 [details]
Example Windows leak log
(Reporter)

Comment 2

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20090108 Minefield/3.1b2pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/20245c2d97d0)

Confirming that this bug was already there at bug 465952 comment 1 time.
(I must have missed it the way I tested back then :-()
Summary: browser_alltabslistener.js leaks intermittently → BrowserChrome browser_alltabslistener.js leaks intermittently, (on my Windows 2000)
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> (I must have missed it the way I tested back then :-()

If I run this test with (for example) the 7 other browser_bug*.js then it seems I can't trigger the leak anymore.

This would explain why I missed it previously and why it can't be seen when running the full test suite :-/
No longer blocks: 460548
Summary: BrowserChrome browser_alltabslistener.js leaks intermittently, (on my Windows 2000) → BrowserChrome browser_alltabslistener.js leaks intermittently, when run alone
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)

Well, it's a little more complex than this:
if I run this test in addition to browser_sanitize-timespans.js, the (bug 465952) leak increase from 55k to 66k ... so they kind of add to each other...

Now, it's up to you.
Blocks: 460548
No longer blocks: 465952
Summary: BrowserChrome browser_alltabslistener.js leaks intermittently, when run alone → BrowserChrome browser_alltabslistener.js leaks intermittently
(Reporter)

Comment 5

10 years ago
(In reply to comment #0)
> NB: I wonder if this leak could be causing the increased bug 465952 leak...

It used not to be needed, but now running this test is one way of triggering bug 465952.

(In reply to comment #3)
> This would explain why I missed it previously and why it can't be seen when
> running the full test suite :-/

This is not right:
I simply, and incorrectly, used to think this leak was part of bug 465952;
and the 70k leak reported by the tinderboxes is these two bugs (afaict fttb).

***

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090109 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/0ff733711384)

(Simply confirming bug still there, up to this current rev..)
(Reporter)

Comment 6

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090117 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/184eadf4e185 + bug 446300 patch)

Thanks to bug 429690, this is now easier to test:
python runtests.py --browser-chrome --test-path=browser/base/content/test/browser_alltabslistener.js --leak-threshold=0 --autorun --close-when-done
(Reporter)

Comment 7

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090122 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/aa69e508e312)

Fwiw, bug 465952 was fixed, but this bug is still there.
(Reporter)

Updated

10 years ago
Summary: BrowserChrome browser_alltabslistener.js leaks intermittently → BrowserChrome browser_alltabslistener.js leaks intermittently, when run alone
(Reporter)

Comment 8

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090228 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/f7f62131998d)

(Bug is still there.)
(Reporter)

Updated

9 years ago
Blocks: 486489
(Reporter)

Updated

9 years ago
Blocks: 438871
Whiteboard: [orange]
(Reporter)

Updated

9 years ago
Depends on: 462410
(Reporter)

Updated

9 years ago
No longer blocks: 486489
(Reporter)

Comment 9

9 years ago
|make NO_FAIL_ON_TEST_ERRORS=1 TEST_PATH=browser/base/content/test/browser_alltabslistener.js -C objdir mochitest-browser-chrome|

Can someone else reproduce?
Keywords: qawanted
Summary: BrowserChrome browser_alltabslistener.js leaks intermittently, when run alone → mochitest-browser-chrome browser_alltabslistener.js leaks intermittently, when run alone
(Reporter)

Updated

9 years ago
Depends on: 486489
No longer depends on: 462410
(Reporter)

Comment 10

9 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090621 Minefield/3.6a1pre] (mozilla-central-win32-unittest/1245592825) (W2Ksp4)

The URLs are different from bug 486489 ones:
{
Leaked URLs:
  https://example.com/browser/browser/base/content/test/alltabslistener.html
  https://example.com/favicon.ico
  http://example.org/browser/browser/base/content/test/alltabslistener.html
  http://example.org/favicon.ico
  http://example.org/browser/browser/base/content/test/alltabslistener.html
  http://example.org/favicon.ico

TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 8939 bytes during test execution
}
Flags: wanted-firefox3.6?
Whiteboard: [orange] → [qaw: reproducible?] [See comment 10] [orange]
No longer depends on: 486489
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1247643832.1247651664.24027.gz

this failure looks like same of this bug but the platform is Mac.
(Reporter)

Comment 12

9 years ago
(In reply to comment #11)
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1247643832.1247651664.24027.gz
> 
> this failure looks like same of this bug but the platform is Mac.

Not at all, afaict:
I eventually filed bug 504340.
Dave, can you please check it? Both files are part of your patch on bug 463387.

Carsten can you run a leak test with the above test?
Flags: wanted-firefox3.5?
This appears to be just a temporary leak caused by something not releasing when loading a favicon. It goes away on its own so I don't think this is a big deal. Not caused by bug 463387

http://tinderbox.mozilla.org/Firefox-Unittest/1253005675.1253007827.29860.gz
No longer blocks: 463387
Summary: mochitest-browser-chrome browser_alltabslistener.js leaks intermittently, when run alone → mochitest-browser-chrome favicon load occasionally leaks

Updated

9 years ago
Keywords: qawanted
(Reporter)

Updated

7 years ago
Flags: wanted-firefox3.6?
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [qaw: reproducible?] [See comment 10] [orange] → [qaw: reproducible?] [See comment 10]
You need to log in before you can comment on or make changes to this bug.