Closed Bug 472978 Opened 12 years ago Closed 12 years ago

[SeaMonkey] TUnit test_special_search.js: all but one bug 463483 new cases fail

Categories

(Toolkit :: Places, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 473734

People

(Reporter: sgautherie, Unassigned)

Details

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090110 SeaMonkey/2.0a3pre] (experimental/_m-c_, home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/6acaaa957e0a
 +http://hg.mozilla.org/comm-central/rev/865f907bb16b)

All cases added by
http://hg.mozilla.org/mozilla-central/rev/67aa0bc48118
fail, except '22.1'.

Failures are like
{
*** test pending
10.1: foo ~ -> is typed
Searching for.. foo ~
*** test finished
*** exiting
*** TEST-UNEXPECTED-FAIL | ../../../../_tests/xpcshell-simple/test_places//autocomplete/head_autocomplete.js | 0 == 2
JS frame :: .../mozilla/tools/test-harness/xpcshell-simple/head.js :: do_throw :: line 101
JS frame :: .../mozilla/tools/test-harness/xpcshell-simple/head.js :: do_check_eq :: line 120
JS frame :: ../../../../_tests/xpcshell-simple/test_places//autocomplete/head_autocomplete.js :: anonymous :: line 127
*** FAIL ***
}

Maybe SeaMonkey preferences need to be updated too ?
Flags: wanted1.9.2?
It looks like bug 426864 new TUnit test_empty_search.js has the same issue:
{
*** test pending
1: Match only typed history
Searching for.. foo ^ ~
*** test finished
*** exiting
*** TEST-UNEXPECTED-FAIL | ../../../../_tests/xpcshell-simple/test_places//autocomplete/head_autocomplete.js | 0 == 2
JS frame :: .../mozilla/tools/test-harness/xpcshell-simple/head.js :: do_throw :: line 101
JS frame :: .../mozilla/tools/test-harness/xpcshell-simple/head.js :: do_check_eq :: line 120
JS frame :: ../../../../_tests/xpcshell-simple/test_places//autocomplete/head_autocomplete.js :: anonymous :: line 127
*** FAIL ***
}
Blocks: 426864
that test needs a browser pref iirc
The tests only need the browser pref, but we were caught with removing/changing a pref we have UI for without warning, so more work needs to be done. I filed bug 473734 for the whole thing that will include what will fix the tests as well.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 473734
V.Duplicate then.

And this has now even been landed on 1.9.1, without waiting for the fix :-(
Status: RESOLVED → VERIFIED
Flags: wanted1.9.2?
OS: Windows 2000 → All
You need to log in before you can comment on or make changes to this bug.