Closed Bug 473734 Opened 11 years ago Closed 11 years ago

Switch matchOnlyTyped to restrict.typed "~" (default.behavior + 32)

Categories

(SeaMonkey :: Location Bar, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.0a3

People

(Reporter: kairo, Assigned: kairo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

We need to do the same as bug 463483 for SeaMonkey, meaning another adjustment to UI prefs as well.

Due to restrict.typed missing in our default prefs (bug 472603 will improve that situation in the future), we're currently failing unit tests that rely on this, originally reported as bug 472978 but I'll dupe it here as the work in this bug will fix them.
Duplicate of this bug: 472978
Attached patch switch to new pref(s) (obsolete) — Splinter Review
Here's the fix for this one, and now it really makes sense that those pref sync functions hand over aField ;-)
Assignee: nobody → kairo
Status: NEW → ASSIGNED
Attachment #357124 - Flags: superreview?(neil)
Attachment #357124 - Flags: review?(neil)
Depends on: 468326
Duplicate of this bug: 473731
Comment on attachment 357124 [details] [diff] [review]
switch to new pref(s)

>-pref("browser.urlbar.matchOnlyTyped", false);
Is there a bug for migrating to places prefs?

>+    document.getElementById("matchOnlyURLs").disabled = matchDisabled;
>     document.getElementById("matchOnlyTyped").disabled = matchDisabled;
IMHO Typed belongs before URLs

>+  // Return the right bit based on the id of "aField"
Hmm, might be better to have
const kBehaviourBit = {
  matchOnlyURLs: 16,
  matchOnlyTyped: 32
};
then use kBehaviourBit[aField.id]
(In reply to comment #4)
> (From update of attachment 357124 [details] [diff] [review])
> >-pref("browser.urlbar.matchOnlyTyped", false);
> Is there a bug for migrating to places prefs?

You mean on profile migration? I don't know of any...

> >+    document.getElementById("matchOnlyURLs").disabled = matchDisabled;
> >     document.getElementById("matchOnlyTyped").disabled = matchDisabled;
> IMHO Typed belongs before URLs

Easy to do :)

> >+  // Return the right bit based on the id of "aField"
> Hmm, might be better to have
> const kBehaviourBit = {
>   matchOnlyURLs: 16,
>   matchOnlyTyped: 32
> };
> then use kBehaviourBit[aField.id]

Sounds like a good idea as well :)
Depends on: 426864
This patch is updated for Neil's previous comments.
Attachment #357124 - Attachment is obsolete: true
Attachment #357178 - Flags: superreview?(neil)
Attachment #357178 - Flags: review?(neil)
Attachment #357124 - Flags: superreview?(neil)
Attachment #357124 - Flags: review?(neil)
Attachment #357178 - Flags: superreview?(neil)
Attachment #357178 - Flags: superreview+
Attachment #357178 - Flags: review?(neil)
Attachment #357178 - Flags: review+
Pushed as http://hg.mozilla.org/comm-central/rev/cd9d93b62fd0
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0a3
V.Fixed, "per" bug 472978 tests.
Status: RESOLVED → VERIFIED
No longer blocks: 474152
You need to log in before you can comment on or make changes to this bug.