Closed Bug 473506 Opened 11 years ago Closed 6 years ago

Synchronize BrowserChrome and Mochitest log formats

Categories

(Testing :: Mochitest, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 600413
mozilla1.9.3a1

People

(Reporter: sgautherie, Assigned: sgautherie)

References

()

Details

(Whiteboard: [Av1: fixed1.9.2a1, fixed1.9.1b99; Bv1a: fixed1.9.2b2 fixed1.9.1.6])

Attachments

(2 files)

At least, I'd like the summary formats to be synchronized.

browser-harness.xul: (BrowserChrome)
{
Browser Chrome Test Summary
	Pass: 1272
	Fail: 0
	Todo: 5
}

SimpleTest.js: (MochiTest, MochiChrome, A11y)
{
1327 INFO Passed: 1177
1328 INFO Failed: 0
1329 INFO Todo:   79
}
Bug 364043 added this to new console output but not to existing file output.

This difference broke my bug 473259 patch Ev1,
because I test locally from the file, whereas buildbot uses the console :-/
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #379695 - Flags: review?(rcampbell)
Blocks: 364043
Attachment #379695 - Flags: review?(rcampbell) → review+
Comment on attachment 379695 [details] [diff] [review]
(Av1) Mochitest: remove '*** ' console output
[Checkin: Comment 2 & 3]


http://hg.mozilla.org/mozilla-central/rev/cf17e49a665a
Attachment #379695 - Attachment description: (Av1) Mochitest: remove '*** ' console output → (Av1) Mochitest: remove '*** ' console output [Checkin: Comment 2]
Whiteboard: [needs 1.9.1 landing: Av1]
Target Milestone: --- → mozilla1.9.2a1
Comment on attachment 379695 [details] [diff] [review]
(Av1) Mochitest: remove '*** ' console output
[Checkin: Comment 2 & 3]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/a973204ab988
Attachment #379695 - Attachment description: (Av1) Mochitest: remove '*** ' console output [Checkin: Comment 2] → (Av1) Mochitest: remove '*** ' console output [Checkin: Comment 2 & 3]
Whiteboard: [needs 1.9.1 landing: Av1] → [fixed1.9.1rc1: Av1]
Blocks: 387455
Bug 387455 added this to text output but it differs from html output,
and more importantly from other Mochitest output(s).

This has always needed a specific case in buildbot: see bug 473259 patch Ev1a.
(That buildbot file will need to be updated in sync' too...)
Attachment #379786 - Flags: review?(rcampbell)
Whiteboard: [fixed1.9.1rc1: Av1] → [fixed1.9.1b99: Av1]
rcampbell, ping for review ?
rcampbell: ping for review?
Attachment #379786 - Flags: review?(rcampbell) → review+
Comment on attachment 379786 [details] [diff] [review]
(Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents
[Checkin: See comment 7+14 & 15 & 16]


http://hg.mozilla.org/mozilla-central/rev/b0c89755c903
Bv1, unbitrotted.
Attachment #379786 - Attachment description: (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents → (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7]
Whiteboard: [fixed1.9.1b99: Av1] → [Av1: fixed1.9.2a1, fixed1.9.1b99]
Target Milestone: mozilla1.9.2a1 → mozilla1.9.3a1
Comment on attachment 379786 [details] [diff] [review]
(Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents
[Checkin: See comment 7+14 & 15 & 16]


http://hg.mozilla.org/releases/mozilla-1.9.2/rev/eaea03ee6784
Attachment #379786 - Attachment description: (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7] → (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7 & 8]
Whiteboard: [Av1: fixed1.9.2a1, fixed1.9.1b99] → [Av1: fixed1.9.2a1, fixed1.9.1b99; Bv1: fixed1.9.2b1]
I backed out patch Bv1 because I missed an additional change in buildbotcustom.
Will reland this patch when bbc is ready.
Comment on attachment 379786 [details] [diff] [review]
(Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents
[Checkin: See comment 7+14 & 15 & 16]


http://hg.mozilla.org/mozilla-central/rev/1d95bcb9b00f
Attachment #379786 - Attachment description: (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7 & 8] → (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7+10 & 8+9]
Depends on: 525163
Can we back this out? Since it landed there have been a ton of orange boxes.
(In reply to comment #11)
> Can we back this out? Since it landed there have been a ton of orange boxes.

I backed this out per https://bugzilla.mozilla.org/show_bug.cgi?id=473259#c55, where Serge says it needs to be backed out because of an earlier backout.

http://hg.mozilla.org/mozilla-central/rev/2bf3249fe4bb
(In reply to comment #11)
> Since it landed there have been a ton of orange boxes.

No, there was only one reported,
the other reports were bug 473259 comment 55 "mess".

(In reply to comment #12)
> I backed this out per https://bugzilla.mozilla.org/show_bug.cgi?id=473259#c55,

Bug 473259 patch was re-landed after that.
Yet, I'll let the situation settle for a while before re-landing this patch...
Comment on attachment 379786 [details] [diff] [review]
(Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents
[Checkin: See comment 7+14 & 15 & 16]


http://hg.mozilla.org/mozilla-central/rev/7f6e2f4abdfd
Attachment #379786 - Attachment description: (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7+10 & 8+9] → (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7+14 & 8+9]
Comment on attachment 379786 [details] [diff] [review]
(Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents
[Checkin: See comment 7+14 & 15 & 16]


http://hg.mozilla.org/releases/mozilla-1.9.2/rev/58087da8caa6
Attachment #379786 - Attachment description: (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7+14 & 8+9] → (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7+14 & 15]
Whiteboard: [Av1: fixed1.9.2a1, fixed1.9.1b99; Bv1: fixed1.9.2b1] → [Av1: fixed1.9.2a1, fixed1.9.1b99; Bv1a: fixed1.9.2b2]
Comment on attachment 379786 [details] [diff] [review]
(Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents
[Checkin: See comment 7+14 & 15 & 16]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/5e85a1d1c673
Attachment #379786 - Attachment description: (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7+14 & 15] → (Bv1) BrowserChrome: always use 'Passed' and 'Failed' idents [Checkin: See comment 7+14 & 15 & 16]
Whiteboard: [Av1: fixed1.9.2a1, fixed1.9.1b99; Bv1a: fixed1.9.2b2] → [Av1: fixed1.9.2a1, fixed1.9.1b99; Bv1a: fixed1.9.2b2 fixed1.9.1.6]
No longer depends on: 525163
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 600413
Component: BrowserTest → Mochitest
You need to log in before you can comment on or make changes to this bug.