Closed Bug 474000 Opened 13 years ago Closed 13 years ago

click+drag message in search messages results window doesn't pick up message

Categories

(MailNews Core :: Backend, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: wsmwk, Assigned: iann_bugzilla)

References

Details

(Keywords: regression)

Attachments

(1 file)

drag message fails from search messages results pane, both imap and pop folders, single folder search and multiple. I did not test Seamonkey

works Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090107 Shredder/3.0b2pre

fails Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090108 Shredder/3.0b2pre

bug Bug 470850?
Not Bug 470850.  I'm not seeing what it might have been from comm-central and mozilla-central checkins, so maybe I got the range wrong. But, d&d from saved searches works fine.

Anyone else see this?  It's the drag that fails - doesn't even pick up the message.
fails also in seamonkey, both local and imap folders
Component: Mail Window Front End → Backend
Product: Thunderbird → MailNews Core
QA Contact: front-end → backend
summary=click+drag message in search messages results window doesn't pick up message   fails also search results for local folder
Summary: drag message fails from search messages results pane → click+drag message in search messages results window doesn't pick up message
Backing the change from Bug 472492 locally fixes the issue.
Depends on: 472492
OS: Windows Vista → All
Hardware: x86 → All
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
The fix to bug 472492 changed from using GetDBView() to using gDBView, this patch fixes the issue caused by that.
Attachment #357449 - Flags: superreview?(neil)
Attachment #357449 - Flags: review?(bienvenu)
Comment on attachment 357449 [details] [diff] [review]
Switch back to GetDBView patch v0.1

As IanN mentioned on IRC, the advanced search window has GetDBView() but not gDBView, instead it's called gSearchView.

Is there any benefit in using a local dbView variable?
Attachment #357449 - Flags: superreview?(neil) → superreview+
Comment on attachment 357449 [details] [diff] [review]
Switch back to GetDBView patch v0.1

as Neil points out, you could say let dbView = GetdBView() but either way is ok.
Attachment #357449 - Flags: review?(bienvenu) → review+
Pushed to comm-central -> http://hg.mozilla.org/comm-central/rev/da4ab57196d6
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
v.fixed
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090202 Shredder/3.0b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.