1-pixel gap on the right side of popup menu border

RESOLVED WORKSFORME

Status

()

Core
XUL
--
minor
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Stanimir Stamenkov, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(8 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18) Gecko/20081031 SeaMonkey/1.1.13 (Spidey; Mnenhy 0.7.5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090117 Minefield/3.2a1pre

Using Windows XP with classic theme and certain font size causes 1-pixel gap to appear on the right side of some popup menu borders, just between the border and the popup shadow.  The display resolution is normal 96dpi (haven't tried with other settings).  The effect is seen with Firefox 3.2 and 3.1 nightly builds as well.

Reproducible: Always

Steps to Reproduce:
1. Setup a default "Windows Classic style" theme (from "Display Properties");
2. In the "Advanced Appearance" dialog change the "Menu" font size from 8 to 9;
3. Start Firefox and observe the Bookmarks -> Recently Bookmarked sub menu.
(Reporter)

Comment 1

10 years ago
Created attachment 357541 [details]
Screenshot - Bookmarks -> Recently Bookmarked sub-menu
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090117 Minefield/3.2a1pre

I tested this with the Windows XP classic theme and the changed font size, but was not able to reproduce the issue. Could you give additional info, e.g. did you try this with a new profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
(Reporter)

Comment 3

10 years ago
> I tested this with the Windows XP classic theme and the changed font size, but
> was not able to reproduce the issue.

Could you mail me (or attach here) a screenshot of your test?

> did you try this with a new profile?

Yes, I did try it with a new profile.  Try observing all sub-menus under the Bookmarks one.  Also try opening closing few pages/tabs, then observe the History -> Recently Closed Tabs.  Seems the effect depends on the width of the popup menu.  Using a fresh new profile the gap is visible at least with the Bookmarks -> "Recently Bookmarked", "Recent Tags" (empty) and "Mozilla Firefox" sub-menus, by my side.
I succeeded in reproducing the problem reliably with the default set of Firefox bookmarks, by expanding the Bookmarks -> Mozilla Firefox folder.

Regression range is http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2007-07-03+19%3A00&maxdate=2007-07-04+22%3A00
so probably caused by Bug 279703.
Blocks: 279703
Status: UNCONFIRMED → NEW
Component: Layout → XUL
Ever confirmed: true
Keywords: regression
QA Contact: layout → xptoolkit.widgets
Version: unspecified → Trunk
(Reporter)

Comment 5

8 years ago
Just for update, still visible with:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a2pre) Gecko/20100206 Minefield/3.7a2pre
(Reporter)

Comment 6

8 years ago
Created attachment 430521 [details]
Edge pixels closeup - an o.k. menu

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a3pre) Gecko/20100304 Minefield/3.7a3pre
(Reporter)

Comment 7

8 years ago
Created attachment 430522 [details]
 Edge pixels closeup - extra right black border

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a3pre) Gecko/20100304 Minefield/3.7a3pre

Using a recent nightly the gap appears black instead of the menu color which makes it a bit less apparent, still it looks funny.
(Reporter)

Comment 8

8 years ago
Created attachment 451099 [details]
1px extra black right border using XP style theme

So, using Windows XP style theme and Firefox 3.6.4 I don't observe menu border gap or extra black border, but using:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a6pre) Gecko/20100614 Minefield/3.7a6pre

I see the extra black border I see using a Windows Classic style theme (see the description how to reproduce - just increase the menu font size from 8 to 9).  On such a light theme it appears even worse.
(Reporter)

Comment 9

8 years ago
Created attachment 458075 [details]
1px transparent gap on the right

Starting with:

Mozilla/5.0 (Windows; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100716 Minefield/4.0b2pre

I observe 1px transparent (and not black or the default window/dialog color) gap on the right between the menu pop-up border and its shadow when using Classic Window theme.
(Reporter)

Comment 10

8 years ago
Created attachment 458077 [details]
1px extra black right border using XP style theme (2)

Mozilla/5.0 (Windows; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100716 Minefield/4.0b2pre

Using a Windows XP style theme I still observe 1px extra black border (compared to the transparent when using Classic theme).

Updated

8 years ago
Severity: normal → minor
(Reporter)

Comment 11

8 years ago
Created attachment 487166 [details]
Appmenu-button Bookmarks show extra black border on the right (Aero)

This still happens with current nightly:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101030 Firefox/4.0b8pre

Note this is on Windows 7 with the default Aero theme which uses a default 9pt Segoe UI menu font (it still happens on XP when the default font is changed to 9pt size).
(Reporter)

Comment 12

8 years ago
Created attachment 487167 [details]
Appmenu-button Web Developer shows cropped right border (Aero)

This new effect I've not previously observed (it happens with Classic theme on Windows 7, too).
(Reporter)

Comment 13

8 years ago
If it happens that the exact menus I've given in the screen shots don't show the defect for you, just try the others available (including from the menu-bar).
I'm guessing your now seeing it because having hardware acceleration on turns on DW and D2D.
(Reporter)

Comment 15

8 years ago
I assume you commented on comment #12.
(Reporter)

Comment 16

8 years ago
Just leaving a cross-reference to Bug 571447.  It describes similar effects but in the context of D2D/DW turned on.  It could be D2D just making the core problem more obvious, as well it could be totally different issue - when switching D2D off I couldn't really see the effect given in comment #12 but I still see the extra black border on the right of popups.
I was making a reference to all the comments since Feb 2010, since D2D and I think DW was working then and needed to be enabled to run D2D, in which case I opened bug 571447 for the DW exposure problem, so maybe we should mark this blocking bug 571447.
(Reporter)

Comment 18

7 years ago
Using the officially released Firefox 4 now, I don't seems to observe this problem anymore - using Windows 7 with hardware acceleration turned on and off (Classic and Aero themes), and on Windows XP (Classic and XP style themes).  Should I mark this as "works for me"?
(In reply to comment #18)
> Using the officially released Firefox 4 now, I don't seems to observe this
> problem anymore - using Windows 7 with hardware acceleration turned on and off
> (Classic and Aero themes), and on Windows XP (Classic and XP style themes). 
> Should I mark this as "works for me"?

Did you try just with D3D9 enabled and DW enabled, not the direct write font, pref, but turn that off, and force on Direct write?  

I think this disappeared as well, Its gone from my setup as of 12/29 - I'm testing my Nvidia 7050 with drivers from october 2010.
(Reporter)

Comment 20

7 years ago
> Did you try just with D3D9 enabled and DW enabled, not the direct write font, 
> pref, but turn that off, and force on Direct write?

I'm not sure what this would exactly mean.  I've tried running a new Firefox 4.0 installation with a fresh new profile (with default settings) on a fairly new Windows 7 system - I didn't observe the issue (while previously I had with pre-4.0-release versions on the same system).

Then I've gone to Tools -> Options: Advanced / General: [ ] Use hardware acceleration when available (unchecked it), restarted the browser, FWIW observed the font rendering is now using the "classic" CrearType rendering (not Direct Write), and observed the problem is not apparent with this configuration, too.

As I've written, I've additionally tried the above with Classic/Themed visual appearances, and on Windows XP.
(Reporter)

Comment 21

7 years ago
Don't know what have fixed it but WFM since Firefox 4.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.