All users were logged out of Bugzilla on October 13th, 2018

"Save As Draft" shouldn't wrap plain text messages

RESOLVED DUPLICATE of bug 155622

Status

RESOLVED DUPLICATE of bug 155622
10 years ago
10 years ago

People

(Reporter: contact, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5
Build Identifier: Mozilla Thunderbird version 2.0.0.19 (20090105)

After I've saved a plain text email as draft, when I reopen it for edition, the text is wrapped, so if I change the paragraphs content, I need to rearrange the lines before sending the email. "Text wrapping" should be made just before sending the email and shouldn't be applied to drafts.

Reproducible: Always

Steps to Reproduce:
1. In Thunderbird, write a new plain text email and put few paragraphs in the textarea.
2. Save this email as draft and close its window.
3. Go to the "Drafts" directory, click right on the previous saved draft and choose "Edit As New...".
Actual Results:  
The email is wrapped to ?? characters (?? represents the value in Preferences > Composition > General > Wrap plain text messages at ?? characters). So if we modify the text, the paragraphs have bad line breaks. Example:

Say we have written this paragraph in the plain text email and we have saved it as draft. When we reopen for edition the draft, the text is wrapped:

Lorem ipsum dolor sit amet, consectetur adipiscing
mauris dictum, erat id fermentum faucibus; duipurus
blandit lectu, et sollicitudin purus qua quis quam
libero. Pede bibendum in, dapibus sit amet, intefis.

Say we want to modify this text before sending it. We add some words:

Lorem ipsum dolor sit amet, consectetur adipiscing 
aWordAdded
mauris dictum, erat id fermentum faucibus; duipurus 
anotherWordAdded
blandit lectu, et sollicitudin purus qua quis quam
libero. Pede bibendum in, dapibus sit amet, intefis.

The line breaks are now bad and we must rearrange the lines.

Expected Results:  
The draft shouldn't be wrapped because the text isn't definitive. A draft is subject to change.

An email should be wrapped just when we send it.
(Reporter)

Updated

10 years ago
Flags: wanted-thunderbird3?

Comment 1

10 years ago
This has been fixed by bug 155622 and works correctly now in Thunderbird 3.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Flags: wanted-thunderbird3?
Resolution: --- → DUPLICATE
Duplicate of bug: 155622
You need to log in before you can comment on or make changes to this bug.