Closed Bug 474238 Opened 16 years ago Closed 4 years ago

DataTransfer loses some of its information after about 5 seconds

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: iannbugzilla, Unassigned)

References

Details

Thunderbird makes use of nsDOMDataTransfer for its drag and drop. If you don't complete your drop within 5 seconds of starting the drag, information retrieved by mozGetDataAt seems to get corrupted.

Steps to reproduce:
Case 1: Within TB try to drag and drop a folder onto the same server doing it within 5 seconds
Case 2: Within TB try to drag and drop a folder onto the same server making sure you take about 10 seconds to do it.

Results
Case 1: Folder gets moved successfully
Case 2: Folder gets copied instead of being moved

If you insert a dump command to look at some of the data, just before http://mxr.mozilla.org/comm-central/source/mail/base/content/folderPane.js#365
something like folders[0].prettyName then for case 1 you get the correct prettyName but for case 2 you get undefined. You get similar results for other information you expect to be there.
mozTypesAt still seems to be giving the correct information out as does mozItemCount
Blocks: 465015
Doing a QI on the folder object seems to workaround the issue.
More likely a Thunderbird issue.
Component: Drag and Drop → General
Product: Core → Thunderbird
QA Contact: drag-drop → general
Version: 1.9.1 Branch → unspecified
doesn't do it with local folders.
Ian, do you still see this?  using version 3.1?

going imap to imap, WFM also with Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre) Gecko/20101106 Thunderbird/3.3a1pre

(In reply to Wayne Mery (:wsmwk) from comment #4)

Ian, do you still see this? using version 3.1?

going imap to imap, WFM also with Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre)
Gecko/20101106 Thunderbird/3.3a1pre

Flags: needinfo?(iann_bugzilla)

I don't see this anymore so probably fixed somewhere in the last 7-8 years :)
WFM

Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(iann_bugzilla)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.