Closed Bug 474325 Opened 11 years ago Closed 11 years ago

Google calendars disabled on startup

Categories

(Calendar :: General, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: James.Peterson, Assigned: Fallen)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090119 Lightning/1.0pre Shredder/3.0b2pre

[Exception... "Component returned failure code: 0x80570015
(NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]"  nsresult:
"0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)"  location: "JS frame ::
file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm
->
file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
:: cmgr_createCalendar :: line 520"  data: no]



Reproducible: Always

Steps to Reproduce:
1. Install lasted build of thunderbird. lightning, and gdata-provider
2. start thunderbird
3. google calendars produce startup exception
4. google calendars are disabled



This Error started after the fix for bug 473973 was completed and may be related.
Whiteboard: DUPEME
Version: unspecified → Trunk
Confirming because I now see this - for my testing post bug 473973 I was using an hourly build (06 I think), I've just updated to the nightly build on the 18th, and it is now broken.

Hence this isn't a regression from bug 473973 but there are two bugs that it could be: bug 469477 or bug 474207 - hopefully I can narrow this down in a little while.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Trying to reproduce the issue resulted in the following error during calendar creation:

Error: SyntaxError: missing ; before statement (file:///.../js/calGoogleCalendar.js)
Source file: file:///.../modules/calUtils.jsm
Line: 78

followed by the one mentioned above.
Whiteboard: DUPEME
Depends on: 469477
Attached patch Fix - v1 β€” β€” Splinter Review
Just a typo from bug 469477.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #357704 - Flags: review?
Attachment #357704 - Flags: review? → review?(bugzilla)
Comment on attachment 357704 [details] [diff] [review]
Fix - v1

I've not tested it, but they sure are a problem.
Attachment #357704 - Flags: review?(bugzilla) → review+
Seems to work from this side.
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/6785834e804c>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Checked with lightning and sunbird build 20090126 -> VERIFIED.
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.