Closed Bug 473973 Opened 11 years ago Closed 11 years ago

Calendar Functions failing (unable to log in)

Categories

(Calendar :: Lightning Only, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: James.Peterson, Assigned: standard8)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090115 Lightning/1.0pre Shredder/3.0b2pre

Jan 16th nightly calendar integration failing.
All of my gdata-provider calendars are being prompted for password auth again but locking up before I can input.
Canceling out of login opens thunderbird but gdata-provider calendars are disabled and I can not add newor edit any events to the calendar with right click.

Reproducible: Always

Steps to Reproduce:
1.Have gdata-provider calendar 
2.Start Thunderbird after update
3.Blank popup will appear that would be a authentication prompt.
4.Close prompt - continue to thunderbird calendar
5.Google calendars are disabled
6.New and edit functions are disabled on calendar



This happened just after I installed update this morning.
I reverted to Jan 15th build and now continues to fail.
Have you update Lightning and gdata-provider to builds from the same date as Thunderbird?

FWIW I posted this warning on the newsgroup earlier today: http://groups.google.com/group/mozilla.dev.apps.thunderbird/msg/de2772c74cbae88f
Component: General → Lightning Only
Product: Thunderbird → Calendar
QA Contact: general → lightning
Version: unspecified → Trunk
I did update lightning and gdata-provider.  This did not fix the issue.
Also I created a new profile to test for corruption and the issue remained.
On my last attempt I removed the .thunderbird profile directory to have it recreated and tested again and the issue persisted.
I will attempt again in a few hours to check if the nightly had not been updated yet.
Well the linux nightly for linux is on the ftp drive (dated the 16th). So this could be an actual problem somewhere.
Do you use a master password? In that case it seems identical to Bug 435557. Or maybe the recent password manager changes from Bug 463058 caused a new issue.

Do you see any calendar related messages in Tools > Error Console?

Does this only happens for calendars via Provider for Google Calendar extension? Or does it happens too using e.g. remote ics, caldav or wcap calendars?
(In reply to comment #5)
> Do you use a master password? In that case it seems identical to Bug 435557. Or
> maybe the recent password manager changes from Bug 463058 caused a new issue.

I've been seeing this, but I've been using mis-matched versions of Thunderbird & Lightning on Mac (i.e. Thunderbird post the Login Manager switch and Lightning before it) - the Mac Lightning nightly has only just started. I took a brief look through the landed patch for bug 463058 and couldn't see any obvious problems (assuming that code works fine, which I guess it would do for Sunbird).

I doubt this is bug 435557 as that would be adding stuff - I think its most likely something in the login manager switch that has caused this.
This is the error I cam getting on startup.

Error: [Exception... "'[JavaScript Error: "headerkids[i] is undefined" {file: "chrome://calendar/content/calendar-month-view.xml" line: 856}]' when calling method: [calIObserver::onPropertyChanged]"  nsresult: "0x80570021 

(NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1215"  data: yes] STACK: 1: [file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1218] notifyFunc
2: [file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1221] calListenerBag_notify
3: [file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:94] anonymous
4: [null:0] null
5: [file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1215] notifyFunc
6: [file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1221] calListenerBag_notify
7: [file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calProviderUtils.jsm:552] cPB_setProperty
8: [null:0] null
9: [file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleSession.js:325] cGS_loginAndContinue
10: [file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleSession.js:477] cGS_asyncItemRequest

Source File: file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1218
Duplicate of this bug: 474042
I'm not sure about the errors in comment 7, but these are interesting:

Error: l.usernameField is null
Source File: file:///Applications/Shredder.app/Contents/MacOS/components/storage-mozStorage.js
Line: 709

Error: Assert failed: [Exception... "'[JavaScript Error: "l.usernameField is null" {file: "file:///Applications/Shredder.app/Contents/MacOS/components/storage-mozStorage.js" line: 709}]' when calling method: [nsILoginManagerStorage::addLogin]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///Applications/Shredder.app/Contents/MacOS/components/nsLoginManager.js :: anonymous :: line 431"  data: yes]
2: [file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calAuthUtils.jsm:140] calPasswordManagerSave
3: [file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleUtils.js:327] passwordManagerSave
4: [file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleSession.js:435] cGS_onResult
5: [file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:246] cGR_fail
6: [file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:258] cGR_succeed
7: [file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:371] cGR_onStreamComplete

Source File: file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/mark/Library/Thunderbird/Profiles/9uumlyqg.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 968


Implies something is wrong with http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/components/passwordmgr/src/nsLoginManagerPrompter.js#310 but I'll have to take a more detailed look later.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think I've found the issue - currently building and testing the possible solution.
Assignee: nobody → bugzilla
Attached patch The fixSplinter Review
This fixes Lightning to do the right thing, the aUsernameField and aPasswordField parameters in nsILoginInfo should be set to "" rather than null as roughly indicated per the documentation on the interface:

http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/components/passwordmgr/public/nsILoginInfo.idl

With this I can add a new password for a google calendar and access it, and it will retain it on restart.

I expect there may be a separate migration issue going from pre-login manager builds to post-login manager, but I think they should be addressed in a separate bug if they can be (and if they are present, I haven't checked).
Attachment #357482 - Flags: review?(philipp)
Attachment #357482 - Flags: review?(philipp) → review+
Comment on attachment 357482 [details] [diff] [review]
The fix

Thanks for looking into this, r=philipp
Patch pushed: http://hg.mozilla.org/comm-central/rev/3d67a6834be5

I think it may have made it in time for today's Lightning nightlies, if not, it will be in tomorrow's.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Summary: Calendar Functions failing → Calendar Functions failing (unable to log in)
Target Milestone: --- → 1.0
OS: Linux → All
Hardware: x86 → All
this went from begging me for my password to now after the update failing to load the calendar altogether...
and now throws [Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]"  nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)"  location: "JS frame :: file:///C:/Users/%user%/AppData/Roaming/Thunderbird/Profiles/unrr2973.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Users/%user%/AppData/Roaming/Thunderbird/Profiles/unrr2973.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js :: cmgr_createCalendar :: line 520"  data: no]

%user% in place of my user name for anonymity.
for further info, this is error number 0x80570015
(In reply to comment #14)
> this went from begging me for my password to now after the update failing to
> load the calendar altogether...

Please can you raise a separate bug for your issues, although possibly related, there looks to be a different cause/underlying issue.
i mean, i can, but i highly doubt it, as it happens in the same bootup process, and throws an error to the same createInstance method...
(In reply to comment #18)
> i mean, i can, but i highly doubt it, as it happens in the same bootup process,
> and throws an error to the same createInstance method...

Errm where do the other stacks on this bug mention createInstance? I also see no mention of calGoogle*.js in your comment as per the other stacks on this bug.

It would also be useful to know if you are using caldav or the google calendar provider, from what I saw or irc today, this may not have fixed caldav but I know its fixed google calendars. This is the other reason I think your bug is a separate bug.
I would like to verify that the login error is fixed but I am now getting this error on startup.

[Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]"  nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)"  location: "JS frame :: file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/jamespet/.thunderbird/amxwosiz.Work/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js :: cmgr_createCalendar :: line 520"  data: no]

If this is a new bug I will file as so but I just wanted to mention.
(In reply to comment #20)
> I would like to verify that the login error is fixed but I am now getting this
> error on startup.
...
> If this is a new bug I will file as so but I just wanted to mention.

YES. Please file a separate bug.
Duplicate of this bug: 474437
still not solved with Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.9.1b3pre) Gecko/20090217 Lightning/1.0pre Shredder/3.0b2pre
when using master password (also not working on windows).
bug only appear when using gdata-provider.xpi
(In reply to comment #23)
> still not solved with Mozilla/5.0 (X11; U; Linux i686 (x86_64); de;
> rv:1.9.1b3pre) Gecko/20090217 Lightning/1.0pre Shredder/3.0b2pre
> when using master password (also not working on windows).

Fritz, please try again with tomorrow's nightly of Lightning and gdata-provider.xpi.
i am not understanding this.  this bug has been gone for like a month.
yes this bug was gone for a long time. I installed the new xpi's on a new shredder this morning on windows. There was a change:

Now i am asked for a master password only one time, but still the window for the passsword dialog is only drawn after i typed the first character of my password. The password question is no more repeated, but calendar is only reachable after i opened addressbook, closed shredder window and opened shredder again from the addressbook extras window. Maybe this is another bug?

Here is some data:

This time i report from a windows box with lightning and gdata-provider from

http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-central/win32-xpi/gdata-provider.xpi 

date of file is 08-Mar-2009 06:39
i am using shredder Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1b4pre) Gecko/20090308 Lightning/1.0pre Shredder/3.0b3pre

Here is the error mentioned in the error console, it is repeated two times.

Fehler: [Exception... "'[JavaScript Error: "this.treebox is null" {file: "chrome://calendar/content/widgets/calendar-list-tree.xml" line: 562}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1215"  data: yes] STACK: 1: [file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1218] notifyFunc
2: [file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1221] calListenerBag_notify
3: [file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:209] cCC_addCalendar
4: [file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:184] anonymous
5: [file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:187] anonymous
6: [null:0] null
7: [chrome://calendar/content/calUtils.js:1832] getCompositeCalendar
8: [chrome://calendar/content/calendar-task-tree.xml:154] 

Quelldatei: file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Zeile: 1218
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.