Open Bug 47434 Opened 21 years ago Updated 3 years ago

Implement statusbar tips for menuitems

Categories

(Core :: XUL, enhancement)

enhancement
Not set
normal

Tracking

()

People

(Reporter: bugzilla, Unassigned)

References

Details

(Keywords: helpwanted, parity-ie, polish)

It would be nice if we supported statusbar tips when you rollover menu items, 
as IE does (and NN 4.x).  I'll do it, but (and this is the fun part ;) I need 
text for every menu item in the product.  Ohhhhh Vera?
Status: NEW → ASSIGNED
Keywords: polish
Target Milestone: --- → M18
Do we really have room for such tips in the status bar? Even once the taskbar is 
nuked and the component bar becomes part of the status bar? Even once the status 
bar gets a language popup menu item?

If we do have room, then ...

Vera, if you don't have time to do this (and I wouldn't be at all surprised), let 
us know and I'll do it.

Blake, for forwards-compatibility, you'll want to plan for an arbitrary number of 
strings for each menu item:
* brief description of what the item does
* brief explanation of why the item is disabled (if it is).

I say arbitrary, because in some cases multiple menu items will share the same 
disabled explanation string, and in other cases a single item will have multiple 
disabled explanation strings.

Only the description string would be shown in a status bar tip (there wouldn't 
really be room for anything else). But with the multi-string scheme, one day we 
can support Balloon Help on Mac OS using the same set of strings. :-)
blah.  My good friend Ben Goodger kindly pointed out that there's no event 
which fires if navigating menu items via the keyboard.  So unless we want to be 
a little inconsistent and only have this fire onmouseover, this is a big fat 
WONTFIX...

(sorry that you wrote all that, Matthew..got a midair collision with you trying 
to say this)
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WONTFIX
> there's no event which fires if navigating menu items via the keyboard

Well, file a bug asking for such an event.
It'll just get futured.  Doing the same to this bug...
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Target Milestone: M18 → Future
Status: REOPENED → ASSIGNED
h'm, well, i'm not exactly jumping up and down for tooltips on menuitems. unless
i'm picturing it incorrectly, this would kinda clutter up the menu/kinda naggy.
but that's just mho/$0.02... not sure how often/useful a tip in the statusbar
would fly, having not performed usibility studies meself. :-)
post-lunch coma made me misread this. this bug doesn't ask about tooltips, it
asks about the statusbar. like what the summary sez. ignore everything but the
last sentence in my comment above. jeepers, time for some caffeine...
QA Contact: sairuh → claudius
somewhere there is an RFE or some such asking for this for the bookmarks menu. You would of course display the URL instead, 
which sounds more difficult
Sorry, I must have missed this while I was on vacation. (Ahhhh....) I think it 
sounds good -- it would be nice to have a demo, some day, if it becomes possible 
to do this. I'm keeping a list of user assistance ideas to investigate once 
we've got the mere basics done, and I'll put this on the list.
Priority: P3 → P5
Ok, this is a real usability issue, i'm sorry we don't want it for netscape6 but
it really is important especially when our menu items are vague (which will happen).

I'm marking a block to remind me that the other item is not really finished even
if I satisfy mpt's request.
Blocks: 54149
Target Milestone: Future → mozilla1.2
> somewhere there is an RFE or some such asking for this for the bookmarks menu.

bug 23460
marking dependency on 63847, reassigning to nobody until that gets fixed.
Assignee: blakeross → nobody
Status: ASSIGNED → NEW
Depends on: 63847
*** Bug 68571 has been marked as a duplicate of this bug. ***
This bug might block bug 23460, "Bookmarks URL should show in status bar at 
mouseover of menuitem", with 5 votes.
> it really is important especially when our menu items are vague (which will
> happen).

So we'll have to fix the menu items. We can't rely on a status bar being there. 
We might have a window like the Bookmarks window open, where the status bar is 
too short to show meaningful help text. Or, we might have no windows open at all.
MPT, I disagree.  Though it's true the status bar may not always be present or
that it may be too short, I suspect it's unrealistic to think that the menu
items can be fixed in such a way to be completely unambiguous and clear to all
users.  So having some sort of tip or hint in the statusbar would still be
better than nothing.  Also, statusbar tips are considered standard in many apps
these days, so it's reasonable to think that users will look for it.
FWIW, I agree that it's good to have additional help. Sometimes, just a
rewording helps some users to understand a menu item (but other users wouldn't
understand the rewording, and only understand the menu item text).
adding self to cc list
Severity: normal → enhancement
Keywords: 4xp
Product: Core → Mozilla Application Suite
Duplicate of this bug: 265764
QA Contact: claudius → guifeatures
Component: XP Apps: GUI Features → UI Design
Assignee: nobody → jag
Priority: P5 → --
QA Contact: guifeatures
Target Milestone: mozilla1.2alpha → ---
Assignee: jag → nobody
Component: UI Design → XUL
Product: SeaMonkey → Core
QA Contact: xptoolkit.widgets
Whiteboard: [parity-IE]
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Keywords: parity-ie
Whiteboard: [parity-IE]
You need to log in before you can comment on or make changes to this bug.