Closed Bug 23460 Opened 23 years ago Closed 12 years ago

Bookmarks URL should show in status bar at mouseover of menuitem

Categories

(SeaMonkey :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bugzilla, Unassigned)

References

Details

When you're in the browser and press Bookmark from the menu and holds your
cursor over a bookmark the URL for that bookmark should both be shown in the
Status bar at the buttom of the screen and be shown as a tooltip.
Assignee: shuang → slamm
Severity: normal → enhancement
Component: UE/UI → Bookmarks
QA Contact: elig → claudius
Tooltips don't display because they're not implemented yet.

Changed severity to "Enhancement Request" --- this is a Windows-only IE feature
that would be nice to have, but its omission certainly not a bug.
If tooltips aren't implemented yet, what about just displaying the URL in the
status bar at the buttom of the screen?
Status: NEW → ASSIGNED
Summary: Holding your mouse cursor over a bookmark in the bookmarks should show the URL of that bookmark in the status bar → Bookmarks URL should show in status bar on mouseover
Target Milestone: M17
Resummarizing. Assigning milestone. Marking Assigned.
annotating summary to differentiate this from bug 10239 which is to display the URL when mousing elsewhere [than the BM 
menu].
OS: Windows 98 → All
Hardware: PC → All
Summary: Bookmarks URL should show in status bar on mouseover → Bookmarks URL should show in status bar when on mouseover of menuitem
Move to M20 target milestone.
Target Milestone: M17 → M21
*** Bug 45570 has been marked as a duplicate of this bug. ***
Keywords: nsbeta3
Just in the status line, please. In the status line *and* as a tooltip would be 
overkill, just as it would be for ordinary links.
Note that the bookmarks menu hides the status bar, if the menu is long enough.
So, tooltips *might* not be a bad idea. But status bar is more important.
Nav triage team: [nsbeta3-]
Summary: Bookmarks URL should show in status bar when on mouseover of menuitem → Bookmarks URL should show in status bar at mouseover of menuitem
Whiteboard: [nsbeta3-]
4xp: severity -> normal
Keywords: 4xp
Severity: enhancement → normal
I think, this should be fixed for Mozilla 1.0. Low cost, high reward.
Keywords: mozilla1.0
Reassigning 79 Bookmarks bugs to Ben.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → ben
Status: ASSIGNED → NEW
This is an easy and safe enhancement that I have done before, however as there
is nothing like an event for "focusing a menuitem with the key arrows", the url
will be displayed only when the onmouseover event is fired.
Apart from that, it's feasible, and it would be a cool thing to have indeed.
Fabian.
Right.  As with 47434.
*** Bug 62683 has been marked as a duplicate of this bug. ***
please also fix (at least look at) bug 64307 since it addresses the more
relevant issue of bookmark visibility (tooltips) and url displaying (statusbar)
while using bookmarks from MySidebar. Thank You.
*** Bug 64013 has been marked as a duplicate of this bug. ***
*** Bug 64892 has been marked as a duplicate of this bug. ***
This should also work for bookmarks hovered over in MySidebar.

This was bug 64892 which has been marked as a duplicate of this one.
Netscape Nav triage team: this is not a Netscape beta stopper.  Please do this 
as a tooltip. adding german to the cc list.
Keywords: nsbeta1-
It seems the majority preference expressed in this bug and its duplicates and 
in (the possible duplicate) bug 10239 is for the bookmark URL to be shown just 
in the status bar. Users are used to looking for URL information in the status 
bar such as when hovering over links, so that should be primary. Tooltips 
should perhaps be an option.
I agree with tpowel. Status bar makes a lot more sense and all the duplicates
request status bar messages. Whoever decided that please comment with your
reasons, thanks.
> this is a Windows-only IE feature that would be nice to have

For the record: 4.x Unix shows the URL in the status bar.
*** Bug 42136 has been marked as a duplicate of this bug. ***
*** Bug 10239 has been marked as a duplicate of this bug. ***
I am also of the opinion to put the information into the status bar. The added
benefit is this is analogous to what is expected when hovering over a link on a
page.
Tooltips on menuitems as indicated by the original poster which means popping up
a tooltip above a menu that has been popped up over the browser also seems
akward to me. I can't remember having seen tooltips on menuitems on any other
app/platform, since you do not really hover over an item.
This bug's severity should be Enhancment (Navigator never had that feature).
Sorry for the spam, but the previous comment is inaccurate. This isn't an 
enhancement. It's 4xp as marked since Navigator 4 and IE5 have this. See Ben 
Bucksch's Unix 4.x comments above and my comments in bug 10239. As I recall 
this feature was actually in Navigator 3 but partially broken in 4 when 
accessed from the bookmarks toolbar button.
This bug might depend on bug 47434.
Marking nsbeta1- bugs as future to get off the radar.
Target Milestone: --- → Future
This is a fairly serious usability issue for the bookmarks menu. For bookmarks
without a good title, there's no way to figure out where they go without going
there.

Since this is 4xp and shouldn't be that complicated to add, it'd be real nice to
have before 1.0.
Status: NEW → ASSIGNED
*** Bug 101714 has been marked as a duplicate of this bug. ***
I am reporter of bug 101714, marked duped of tha tone.
I would like to add some comments regarding the tooltip side of the original bug
which has been 

- IE has the feature. why not a 'parity-ie' keyword, even if it has only be used
once in the bug reports (I've seen several opera-parity though)
- this bug creates an inconsistency in the perosnal toolbar between bookmarks
and bookmarks within folders. 

Note the subject should maybe changed so that other people don't miss it and do
not report bugs for the tooltip, like mine.
Proposal: "Bookmarks URL should show in status bar [and tooltip] at mouseover of
menuitem
No, we don't need to show the URL in 2 places (statusbar and tooltip) - the
statusbar is enough. 

We really need a *Titletip* that shows the full text of the bookmark "Name" when
it is truncated. That is far more useful than showing the URL twice. Also, it's
probably not possible to show a tooltip and a titletip at the same time (that
would look pretty bad anyhow).
the status bar usually gets obscured by a bookmark menu, because it is naturally
very long and usually quite wide.  however, i think as a bandaid fix it should
be harmless to implement

having tooltips appear in menus is an odd suggestion, and i think it should be
avoided. over time, the behavior of menus has become well defined and their
sanctity should not be sacrificed for what amounts to bad practice, or
inefficient system management.  The bookmarking system is really at fault for
this, we should instead empower users by providing them with more effective
bookmark management.  If a bookmark is poorly titled, it is either the fault of
the web author, or the fault of the bookmarker (or a cumbersome bookmarking
system), neither of which should system menus be held accountable for.  A better
solution lies in redesigning the bookmarking system, and empowering users with
*manageable* access to visited sites. 
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW
See also bug 88541, a similar bug for the menus next to the back and forward 
buttons.
*** Bug 117595 has been marked as a duplicate of this bug. ***
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben
adding self to cc list
I have filed the related, if not conflicting, bug 135962: [RFE] Show description
field in tooltip on hover over bookmarks.
Although I don't believe that the bug I submitted is a dupe of this one, it has
so been marked. Therefore I'll move my comment here:

After a short delay, hovering over a bookmark should bring up a tooltip
containing the text of the description field from the bookmark's properties if
it exists.

When I fill out the description field, I would like to be able to see it again
without having to open the properties dialog for the bookmark.  The vast
majority of bookmarks will not have a description so I don't think it would be
that bothersome to have the occasional tooltip up.

I did make a special effort to add the description.  Tooltips would help me
remember why I bookmarked some obscure site. (eg. "Study quotes from Tim's
thesis!") Likewise, I leave notes about syntax and usage in "shortcut" bookmarks
I've created for myself and often share with others. (eg. "findbyname [last,
first] (case sensitive!)")
Sorry.  By "shortcut," I mean "custom keyword" bookmarks.
I maintain my list of bugs that I'm working on, gonna work on, etc in Bookmarks.
It would be nice if I could see more than the first 5 letters of each bookmark
without making the sidebar extremely large.

*Adding this to my bugs to work on (in the far far future) list
*** Bug 147161 has been marked as a duplicate of this bug. ***
I have a fix for this that causes the URL to show up in the statusbar when
mousing over links and folders in the personal toolbar and the bookmarks menu.

http://www.worldtimzone.com/mozilla/bugs/bug23460/

As others have mentioned, this has the limitation that it only works when using
the mouse; you can't see the URL in the statusbar when using the keyboard to
access the bookmarks menu. It also tries to preserve the statusbar at the point
you start interacting with the bookmarks. If a page is loading while you are
working with the bookmarks, it can cause the statusbar to end up with the
"wrong" messsage left over.  Is there a way to be notified of statusbar changes
due to page loading/progress?
Is Tim Powell's fix working for anybody?  I have not personally had success yet.
This now works in Firebird for the Bookmarks menu and the Go menu (via either
the mouse or keyboard).  In the new toolkit (used by Firebird and Thunderbird)
any menu item on a menu bar (or within a menu bar's submenus) can have
statustext associated with it.

*** Bug 217995 has been marked as a duplicate of this bug. ***
Re comment 28:
*Present in NNv4: 4xp.
*Never was in Mozilla: enhancement !

Re comment 48:
Any chance of a back-port from FireBird to Mozilla Suite ?
Severity: normal → enhancement
Just FYI, 4xp is by definition no enhancement (see comment 10). I don't care much.
4xp means normal--not enhancement--bug. It's hard to believe that there's
*still* 4xp problems in Mozilla. At least my version of Mozilla does the right
thing now after I applied my patch (see comment #46 ) A better choice would be
to port Firebird's changes.
Severity: enhancement → normal
Product: Browser → Seamonkey
It seems the summary should be rephrased to reflect the wider scope of this bug.
(In reply to comment #53)
> It seems the summary should be rephrased to reflect the wider scope of this
> bug.

Based on your email response,
I briefly looked at bug 62683 and bug 135962...
Then, I guess bug 237592 might be closer to what you are interested in.
WFM. Mozilla/5.0 (Firefox 2.0; Kubuntu)
(In reply to comment #55)
> WFM. Mozilla/5.0 (Firefox 2.0; Kubuntu)

Yes. This bug is about Seamonkey.
Confirmed that it works in FF2, but not in Seamonkey 1.1b.
Assignee: bugs → nobody
Priority: P3 → --
QA Contact: claudius → bookmarks
Whiteboard: [nsbeta3-]
Target Milestone: Future → ---
How can you say that it works in FF2 ?
In my FF2.0.0.1 hovering on bookmarks menu display nothing on the statusbar (4xp)

The original topic is about showing a preview of the url the browser is about to load, before clicking the mouse in a bookmark.
This seems to have been implemented on trunk (and 2.1a3) as part of the transition to Places-based bookmarks (for the Personal Toolbar, Sidebar and menu). Marking WFM.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.