Last Comment Bug 474401 - Firefox on Mac does not register itself as being capable of opening SVG files
: Firefox on Mac does not register itself as being capable of opening SVG files
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13)
:
Mentors:
: 359548 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 02:41 PST by Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13)
Modified: 2013-02-14 17:35 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.35 KB, patch)
2011-01-26 04:50 PST, Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13)
jaas: review+
Details | Diff | Review

Description Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2009-01-20 02:41:52 PST
Firefox on Mac does not register itself as being capable of opening SVG files.
Comment 1 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2009-01-20 02:47:18 PST
Being new to Mac I'm having trouble figuring out what needs to happen to fix this. Any pointers Josh?
Comment 2 Josh Aas 2009-01-20 07:02:40 PST
Probably need to edit this file with an svg extension:

http://mxr.mozilla.org/mozilla-central/source/browser/app/macbuild/Contents/Info.plist.in
Comment 3 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2009-01-20 07:31:36 PST
Thanks!
Comment 4 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2011-01-26 04:50:05 PST
Created attachment 507082 [details] [diff] [review]
patch

Just had someone ask if this'll be fixed for FF4. Not sure if that's possible, but anyway the patch is trivial so here it is.
Comment 5 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2011-01-26 04:51:08 PST
Tested and works fine BTW.
Comment 6 Josh Aas 2011-04-19 10:50:42 PDT
Comment on attachment 507082 [details] [diff] [review]
patch

Seems like there are some unnecessary things in here. For example, I don't think the MIME entry is helpful in any way.

Why not just add "svg" to the existing list of image formats we support, right after "<string>gif</string>"? That would be a one-line patch.
Comment 7 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2011-04-19 14:09:15 PDT
Sometimes I really hate bugzilla. Back when I originally requested review and bugzilla silently dropped the email address I used intending to get review from you I'd spent hours researching this and knew exactly why I took this route. Months on I've now forgotten. *sigh*

One thing I did do was take a look a what Safari and Chrome use though, and Safari does this. I guess I'm going to have to dig back into this again and follow all the "this mechanism is deprecated by this mechanism, which is deprecated by this, which is..." links I followed previously to figure out the rational though.
Comment 8 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2011-04-19 14:23:13 PDT
In fact it seems Chrome has changed to have exactly the same section as Safari now. They both have:

		<dict>
			<key>CFBundleTypeExtensions</key>
			<array>
				<string>svg</string>
			</array>
			<key>CFBundleTypeIconFile</key>
			<string>document.icns</string>
			<key>CFBundleTypeMIMETypes</key>
			<array>
				<string>image/svg+xml</string>
			</array>
			<key>CFBundleTypeName</key>
			<string>SVG document</string>
			<key>CFBundleTypeRole</key>
			<string>Viewer</string>
			<key>NSDocumentClass</key>
			<string>BrowserDocument</string>
		</dict>
Comment 9 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2011-04-19 14:25:53 PDT
If I recall correctly, the difference was that older versions of Chrome did not have the CFBundleTypeMIMETypes key.
Comment 10 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2011-04-19 14:47:03 PDT
(In reply to comment #6)
> Why not just add "svg" to the existing list of image formats we support, right
> after "<string>gif</string>"? That would be a one-line patch.

And to answer that question, because SVG is primarily a document type, with an option to treat it in a restricted way as an image. It's not primarily an image.
Comment 11 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2011-04-19 14:48:24 PDT
Comment on attachment 507082 [details] [diff] [review]
patch

Re-requesting review, since I'm hoping the above is enough to persuade that this patch is correct and save me from trawling back through MDC docs.
Comment 12 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2011-04-20 10:22:51 PDT
Thanks!

Pushed http://hg.mozilla.org/mozilla-central/rev/1993865501f5
Comment 13 Matthew N. [:MattN] (behind on reviews) 2013-02-14 17:35:09 PST
*** Bug 359548 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.