RSS feed errors when http:// missing in Link

VERIFIED DUPLICATE of bug 364677

Status

()

Firefox
RSS Discovery and Preview
--
minor
VERIFIED DUPLICATE of bug 364677
9 years ago
9 years ago

People

(Reporter: Antony, Unassigned)

Tracking

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 (.NET CLR 3.5.30729)

If you serve RSS as text/xml and are missing the http:// part for the main RSS link tag Firefox simply displays the XML with an error relating to style.

If you serve the same page with application/rss+xml it won't error and displays the standard holding page for FF / RSS display.

Although the first part is not a bug - probably an improvement,
a) the warning doesn't indicate that the error lies in the actual content not structure or how the page is served
b) this should probably be reflected in the application/rss+xml content type as well.

Hope that helps.

Reproducible: Always

Steps to Reproduce:
1. Create an RSS standard feed - example on Wikipedia is sufficient
2. Serve page as application/xml and make sure http:// is not in the initial link tag
3. View the page


Expected Results:  
I expected to see the standard Firefox RSS display page.

Updated

9 years ago
Version: unspecified → 3.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 364677
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.