Last Comment Bug 474738 - Search description doesn't explain when the search type is "not equals"
: Search description doesn't explain when the search type is "not equals"
Status: RESOLVED FIXED
[wanted-bmo]
: ue
Product: Bugzilla
Classification: Server Software
Component: Query/Bug List (show other bugs)
: 3.3.1
: All All
: P3 normal with 4 votes (vote)
: Bugzilla 3.4
Assigned To: Max Kanat-Alexander
: default-qa
:
Mentors:
https://landfill.bugzilla.org/bugzill...
: 528960 541383 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 19:53 PST by Vitaly Fedrushkov
Modified: 2011-05-19 09:32 PDT (History)
12 users (show)
LpSolit: approval+
LpSolit: approval3.6+
mkanat: blocking3.6+
LpSolit: approval3.4+
mkanat: blocking3.4.6+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1 (506 bytes, patch)
2010-02-27 14:48 PST, Max Kanat-Alexander
no flags Details | Diff | Splinter Review
v2 (677 bytes, patch)
2010-02-27 19:03 PST, Max Kanat-Alexander
LpSolit: review+
Details | Diff | Splinter Review

Description Vitaly Fedrushkov 2009-01-21 19:53:47 PST
Search description for this URL:

    * Assignee: vitaly.fedrushkov@gmail.com
    * Reporter: vitaly.fedrushkov@gmail.com
    * Status: UNCONFIRMED

while boolean chart says 'Status is not equal to UNCONFIRMED'
Comment 1 Max Kanat-Alexander 2009-01-21 20:01:59 PST
You can add &debug=1 if you really want a lot of information about exactly what type of chart you're using. I purposely implemented search descriptions in a way that they don't show the chart you're using. I tried doing it at first, but it was complex and wasn't very pretty.

I agree that it might be nice to show symbols for certain types of searches, like "not equal to", though. But it's not a very high priority, and probably won't be fixed for 3.4.
Comment 2 tttttg 2009-09-15 12:45:00 PDT
I have two named searches with the same set of filters, the only difference is that one has "Target Milestone is not equal to Future", the other one has "Target Milestone is equal to Future".

I see exactly the same search description for both searches that states "Target Milestone: Future", which is plain wrong. It would be better if nothing was displayed, at least it wouldn't be so misleading.
Comment 3 Max Kanat-Alexander 2009-11-16 12:08:11 PST
*** Bug 528960 has been marked as a duplicate of this bug. ***
Comment 4 Frédéric Buclin 2009-11-16 12:11:14 PST
We all agree that it's confusing as is. It's very easy to add the relationship between a field and its value.
Comment 5 Max Kanat-Alexander 2009-11-16 14:02:14 PST
  Yeah, see https://bugzilla.mozilla.org/show_bug.cgi?id=528960#c7 for my thoughts on how this would ideally work.

  (Except one slight modification is that it would be nice to use an actual "not equals" glyph if one is standardly available in browser fonts, instead of "!=".)
Comment 6 Frédéric Buclin 2010-01-22 13:22:04 PST
*** Bug 541383 has been marked as a duplicate of this bug. ***
Comment 7 Reed Loden [:reed] (use needinfo?) 2010-02-27 01:05:09 PST
This needs to be fixed for 3.6, even if it means just taking a simple patch like what's in bug 528960.
Comment 8 Guy Pyrzak 2010-02-27 08:25:50 PST
Perhaps I'm being a bit dumb about this but is the BIG problem that the query is for "NOT equal" and the result appears as if it is "equal to"? I agree that's a bad thing. 

I kinda wish we could use a ! to say not but i think that's a bit computer sciencey, maybe we just do NOT(Status: UNCONFIRMED) ?

Is there a good standard way to show not equal to? I did like how the colon was kinda ambiguous between the equal to, contains etc.
Comment 9 Max Kanat-Alexander 2010-02-27 14:47:34 PST
Turns out I'd always intended the code to behave that way and it simply wasn't working right for notequals.
Comment 10 Max Kanat-Alexander 2010-02-27 14:48:00 PST
Created attachment 429359 [details] [diff] [review]
v1

One-character patch.
Comment 11 Reed Loden [:reed] (use needinfo?) 2010-02-27 17:36:32 PST
(In reply to comment #9)
> Turns out I'd always intended the code to behave that way and it simply wasn't
> working right for notequals.

Is notequals what is actually causing all of the problems mentioned in bug 528960, comment #0? Seems like those issues are tied to "does not contain the string" rather than "not equal to"...
Comment 12 Max Kanat-Alexander 2010-02-27 19:03:47 PST
Created attachment 429371 [details] [diff] [review]
v2

This version includes all the negatives.
Comment 13 Vitaly Fedrushkov 2010-02-28 07:02:44 PST
(In reply to comment #8)
> Is there a good standard way to show not equal to? 

Why not 

http://www.fileformat.info/info/unicode/char/2260/index.htm

?
Comment 14 Max Kanat-Alexander 2010-02-28 08:35:09 PST
  That's what I was thinking as well, Vitaly. It would have to be a bit bigger than usual so people could clearly see the slash through it.

  However, changing the search descriptions to glyphs would be a separate bug from this one.
Comment 15 Frédéric Buclin 2010-02-28 09:12:06 PST
Comment on attachment 429371 [details] [diff] [review]
v2

r=LpSolit
Comment 16 Max Kanat-Alexander 2010-02-28 15:56:49 PST
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/                       
modified template/en/default/list/list.html.tmpl
Committed revision 7035. 

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.6/                         
modified template/en/default/list/list.html.tmpl
Committed revision 7006.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.4/                         
modified template/en/default/list/list.html.tmpl
Committed revision 6733.
Comment 17 ravi singh 2011-05-19 09:32:39 PDT
4rdf dddddd fawd fawd efew3 3erfdcv Erfc Afc Ef d @WEDRf v f WE#QRfexs   ewrt sd Sds sdasc ASdAc zc acascf zcc ccc Zasfaf sdAcsawd vzv sfc SDvvrw vv gv s  g vuhgr  urthg ifgoiuergkijkfjguujriao;; ;poplhyw54ui7

Note You need to log in before you can comment on or make changes to this bug.