The [details] string is duplicated when replying to a comment containing a link to an attachment

RESOLVED FIXED in Bugzilla 3.6

Status

()

defect
--
trivial
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: dennis.benn, Assigned: LpSolit)

Tracking

unspecified
Bugzilla 3.6
Bug Flags:
approval +
approval4.0 +
approval3.6 +

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.2) Gecko/2008090514 Firefox/3.0.2
Build Identifier: 

If I reply to a comment which has a linked attachment the link to the detail page is doubled. It happens each time somebody replys to a comment with link to an attachment.

In the commentfield it looks like this:
> I like attachment 1 [details] [diff] [review]
Or after the second reply:
>> I like attachment 1 [details] [diff] [review] [details]

Reproducible: Always

Steps to Reproduce:
1. Write a comment with link to an attachment.
2. Reply to your own comment.
3. See the doubled [details] hint.
(Assignee)

Updated

10 years ago
Whiteboard: DUPEME?
(Assignee)

Comment 1

10 years ago
I pretty sure this is a duplicate, but I cannot find it. Marking as NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: DUPEME?
(Assignee)

Updated

9 years ago
Duplicate of this bug: 561380
(Assignee)

Comment 3

9 years ago
Posted patch patch, v1Splinter Review
Assignee: create-and-change → LpSolit
Status: NEW → ASSIGNED
Attachment #487073 - Flags: review?(mkanat)
Comment on attachment 487073 [details] [diff] [review]
patch, v1

Hmm, why the :? in the regex? Is there a situation where there will be a colon there?
Comment on attachment 487073 [details] [diff] [review]
patch, v1

I suspect that you meant ?: instead. If that's the case, then this looks fine, yeah, just fix that on checkin.
Attachment #487073 - Flags: review?(mkanat) → review+

Updated

9 years ago
Flags: approval4.0+
Flags: approval3.6+
Flags: approval+
Target Milestone: --- → Bugzilla 3.6
(Assignee)

Comment 6

9 years ago
(In reply to comment #5)
> I suspect that you meant ?: instead. If that's the case, then this looks fine,
> yeah, just fix that on checkin.

Yeah, that's what I meant, sorry. :) The regexp was still working correctly, because $3 is ignored.
(Assignee)

Comment 7

9 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Template.pm
Committed revision 7595.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified Bugzilla/Template.pm
Committed revision 7475.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified Bugzilla/Template.pm
Committed revision 7204.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Summary: [details] field doubled if click on reply to a comment with link to an attachment → The [details] string is duplicated when replying to a comment containing a link to an attachment
You need to log in before you can comment on or make changes to this bug.