Selecting an auto-complete entry while adding tags in bookmarks properties dialog should remove the highlight

RESOLVED DUPLICATE of bug 462661

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 462661
9 years ago
8 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

3.5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090121 Shiretoko/3.1b3pre Ubiquity/0.1.5 ID:20090121023015

If an entry from the tags auto-complete list is chosen, the tag is partly highlighted. That makes it hard to enter further tags. Users are forced to hit the right arrow key to continue. Selecting a tag should automatically place the cursor behind the word and nothing should be highlighted. That's the way we are using all other auto-complete instances.

Steps:
1. Bookmark a page and enter a tag via the star panel
2. Add another bookmark and go to the tags field
3. Enter the first letters of the already set tag in step 1
4. The auto-complete pop-up comes up and press Enter

After step 4 the tag has been auto-completed but it's partly highlighted.
Is this bug not already covered by bug 462661 which is concerned about having to press the right arrow key to clear the highlight after selecting a tag?

Also is there a bug on file for using the comma as a tag selector as well as enter? This was proposed initially in bug 415960 comment 33 "so why not using ',' or enter to select the first suggestion? Comma is our separator for multiple tags to it would be great to have it as selector."
(Reporter)

Comment 2

9 years ago
Damn, you are right. It's hard to lose track over own bugs. :/
No longer blocks: 415960
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 462661
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.