Last Comment Bug 475358 - F1 opens tabs a little too easy
: F1 opens tabs a little too easy
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: Keyboard Navigation (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 484654 525455 576886 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-26 08:53 PST by Mike Kaply [:mkaply]
Modified: 2016-09-26 09:30 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mike Kaply [:mkaply] 2009-01-26 08:53:19 PST
F1 opens a tab for help, but if you hold it down for just a second too long, you get like 5 tabs.

We should detect the F1 repeat flag and not continue to open tabs.
Comment 1 Daniel Holbert [:dholbert] 2009-06-29 13:20:09 PDT
Confirmed on Linux. OS --> All.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090629 Minefield/3.6a1pre
Comment 2 u88484 2009-08-19 05:19:51 PDT
http://blog.mozilla.com/metrics/2009/08/18/cats-love-firefox-support/
http://blog.mozilla.com/metrics/2009/02/06/analytics-and-firefox-support/
http://blog.mozilla.com/metrics/2009/02/19/how-do-firefox-users-use-firefox-support/

Reading those articles shows that SUMO has a huge bounce rate and the first article explains that cats seem to be a big culprit from stepping on the keyboard (I can definitely vouch for this as my cats do this all the time and I come back with dozens of SUMO tabs opened).

I believe detecting the F1 repeat flat would help this situation out a lot and save mozilla some bandwidth and users from having to close lots of uneeded tabs.
Comment 3 David Tenser [:djst] 2009-08-19 06:37:12 PDT
Indeed, this would be very good to fix. 

As a side-note, we're about to launch another test that will see how the bounce rate differs between people hitting F1 vs people choosing Help from the menu. If it turns out that the bounce rate for F1 is well over 90%, I would argue for the removal of the F1 key bound to Firefox Help altogether.
Comment 4 John P Baker 2009-10-30 08:22:26 PDT
*** Bug 525455 has been marked as a duplicate of this bug. ***
Comment 5 Mike Kaply [:mkaply] 2009-10-30 09:45:43 PDT
Actually, upon looking, this is more pervasive than I thought.

You just have to find the right shortcuts.

Ctrl+T to open tab. over a second. a zillion tabs.
ctrl+W to close a tab. over a second. lose all your tabs.

I'd be really curious to see how other apps behave in this regard. With shortcut keys in particular, are repeat codes ignored?
Comment 6 Bartosz Wucke 2010-01-01 07:07:41 PST

*** This bug has been marked as a duplicate of bug 484654 ***
Comment 7 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2010-01-02 08:57:16 PST
*** Bug 484654 has been marked as a duplicate of this bug. ***
Comment 8 Kari Halsted 2010-04-30 13:51:07 PDT
+1 for fixing. My cat is also my use case.

A sampling of apps that open Help *one* time, regardless of how long you hold down F1:
- Eclipse IDE (on Windows)
- Internet Explorer 8
- Word
- Photoshop

On the other hand, Windows XP opens lots of help windows if you hold down F1, so FF is as least as good as Windows in this matter. :)
Comment 9 Mike Beltzner [:beltzner, not reading bugmail] 2010-04-30 13:55:23 PDT
This isn't really keyboard navigation, but I agree that we should fix. Is there a simple F1 repeat flag that we can listen for?
Comment 10 Bartosz Wucke 2010-05-08 17:19:36 PDT
Please note by assigning Bug 484654 as duplicate of this, you have reduced the severity. Bug 484654 is critical, and not without reason - on Linux holding down F1 for 10s or so causes total browser freeze. On Windows - long enough causes crash. This is NOT just a matter of aesthetics and discomfort.
Comment 11 Robert Longson 2010-07-04 23:31:33 PDT
*** Bug 576886 has been marked as a duplicate of this bug. ***
Comment 12 Mike Kaply [:mkaply] 2015-03-26 08:25:35 PDT
F1 doesn't do anything at all anymore. Was that on purpose?
Comment 13 Mike Kaply [:mkaply] 2016-09-26 09:30:58 PDT
F1 no longer opens help so this isn't an issue.

Note You need to log in before you can comment on or make changes to this bug.