Closed Bug 475571 Opened 11 years ago Closed 11 years ago

10% Ts regression on boxset from Growl landing

Categories

(Camino Graveyard :: General, defect)

All
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: alqahira, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: perf, regression)

Ts went from between 1240-1270ms to between 1375-1395 after the Growl landing, or about a 10% regression.

By comparison, Ts remained essentially unchanged on cb-xserve01 and went down(!) from 1180-1205ms range to 1135-1150ms range on cb-minibinus01, or about a 4% Ts win!

boxset is one of two shared builds (cb-miniosx01, which runs no tests, is the other), which I assume is at least part of the perf hit (see also bug 405542)?
Per mento in this morning's meeting, this is more-or-less expected in shared builds:

[12:37pm] mento: i think that the problem is that dyld's workload is just plain heavier with the shared build
[12:37pm] mento: it's not really a growl or sparkle or framework problem
[12:37pm] mento: it's a huge symbol table to resolve problem that has just gotten huger
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Per Chris Forsythe, it might be worth trying to remove bundleWithIdentifier: from the Growl framework to see if that helps [https://bugs.launchpad.net/growl/+bug/307918].
Status: RESOLVED → VERIFIED
Switching to lazy loading to fix the 10.6 issue described in bug 510740 probably fixed this; see bug 283100 comment 70 (-perf is a shared build).
You need to log in before you can comment on or make changes to this bug.