Pressing Esc while having the tag autocomplete open closes the bookmarks panel

VERIFIED FIXED in Firefox 3.6a1

Status

()

defect
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: whimboo, Assigned: mak)

Tracking

({dataloss, polish, verified1.9.1})

3.5 Branch
Firefox 3.6a1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090127 Shiretoko/3.1b3pre Ubiquity/0.1.5 ID:20090127021057

This bug is similar to bug 462662 but handles the Esc key. Until know we still close the dialog even when the tag auto-completion menu is open.

Steps:
1. Open a page and bookmark it with a tag
2. Open another page and bookmark it too (via Ctrl/Cmd+D)
3. Selecting the tag field and enter the first letter from the tag of step 1
4. Press Esc

With step 4 we only should close the auto-completion menu but not the bookmarks panel.
mh, ESC is however an acronym to interrupt an operation, something to polish but probably less negative than saving a full dialog on enter through an autoselect.
Keywords: polish
Speaking in that way it's more a dataloss issue. When someone is hitting accidentally the Esc key while having already entered another name and other tags everything is lost. Added bookmarks can easily be removed.
Keywords: dataloss
Posted patch patch v1.0 (obsolete) — Splinter Review
this should be enough
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #359659 - Flags: review?(dietrich)
Comment on attachment 359659 [details] [diff] [review]
patch v1.0

r=me. please add a comment describing the cases this covers.
Attachment #359659 - Flags: review?(dietrich) → review+
Posted patch patch v1.1Splinter Review
Attachment #359659 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/01748c44e5db
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.2a1
Comment on attachment 359734 [details] [diff] [review]
patch v1.1

minor polish, low risk
Attachment #359734 - Flags: approval1.9.1?
Verified with:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090131 Minefield/3.2a1pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090201 Minefield/3.2a1pre

Aakash, can you include this into the litmus test, you already have created on bug 462662? But lets wait for the 3.1 branch fix.
Status: RESOLVED → VERIFIED
Flags: in-litmus?
Ok, the litmus test case, https://litmus.mozilla.org/show_test.cgi?id=7468 , was updated to regression test this bug.
Flags: in-litmus? → in-litmus+
Tracy, we left the question mark because this test cannot be enabled right now. We need the check-in for FF3.1 first. Do you see a better way to handle disabled tests or tests which were created before the original bug will be filed?
Flags: in-litmus+ → in-litmus?
Re-enabling the litmus test case as this has been verified FIXED
Flags: in-litmus? → in-litmus+
Aakash, have you read comment 10? There was no change yet. The patch isn't in 1.9.1.
Flags: in-litmus+ → in-litmus?
Depends on: 485458
a test is being added in bug 485458
Flags: in-testsuite?
Flags: in-testsuite? → in-testsuite+
With the automated test we don't need a Litmus test anymore. Removing flag.
Flags: in-litmus?
Comment on attachment 359734 [details] [diff] [review]
patch v1.1

a191=beltzner
Attachment #359734 - Flags: approval1.9.1? → approval1.9.1+
Verified fixed on 1.9.1 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090416 Shiretoko/3.5b4pre ID:20090416030924 and an appropriate build on WinXP.
Flags: in-litmus-
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.