Program hangs on massive deleting emails

RESOLVED DUPLICATE of bug 452221

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED DUPLICATE of bug 452221
9 years ago
8 years ago

People

(Reporter: Adam, Unassigned)

Tracking

({hang})

x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: freezes on message delete proccess)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; pl; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Thunderbird 2.0.0.19 (20081209)

Bugs happens whenever i try to delete more than few thousand messages ( by deleting i mean moving from current folder to trash/bin ) it seem to work fine for around 1,500 messages, but program hangs when i try to delete for ex. 12,000 messages at once. Last time it hanged for message like 11,800 of 12,000. 

Of course if i force quit it and re-open it the messages were there so i have to delete them in chunks around 1,500 messages.

Good luck fixing it.

Reproducible: Always

Steps to Reproduce:
1.Focus 12,000
2.Press DELETE
3.

No special settings except its in sub-folder
Actual Results:  
It hanged as always

Expected Results:  
Deleted messages
(Reporter)

Updated

9 years ago
Keywords: hang
Whiteboard: freezes on message delete proccess
Version: unspecified → 2.0
The server needs a very long time to delete 12k messages and in that case it looks like TB hangs. I think this should be already fixed with TB3
Sounds to be one of next;
 (a) Bug 296453, or Bug 452221, or combination of both.
     (bug summary of Bug 296453 still says "IMAP issue", but not IMAP only issue)
 (b) If IMAP, it simply takes very long to delete many mails at IMAP server.

IMAP folder? POP3 folder(local mail folder)?  If IMAP, move to Trash model?
Problem when move to Trash by Drag&Drop? Or when Delete key or Delete menu? Or when both?
"Time required to delete" is linear to "number of mails deleted"?
Deep or long thread of mails exists?
(Reporter)

Comment 3

9 years ago
It's fully local, i've preferences set to download my mail from servers. Seconds yes i know the time is linear to number of mails deleted. The point is, it deletes them very fast ( at least progress bar says so ) until it reaches mail like 11,000 then it hangs. Yes it happens when i press the delete button. Didn't try to drag&drop it.
(Reporter)

Comment 4

9 years ago
It will sound wierd but actually when im selecting backwards, i mean in order from bot to top it's working kinda faster and it doesnt hang up at the moment that natural top to bot order does.
Adam, have you read Bug 452221 I already pointed?
(Reporter)

Comment 6

9 years ago
Sorry i didn't, yes seems it's same, cause most of those mails had same subject. My bad. I've sorted them by subject not by newest but i guess it doesn't matter. 
Thanks for pointing that again.

Comment 7

9 years ago
duping. reopen the bug if your problem isn't solved after bug 452221 is fixed and you test a trunk build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 452221
You need to log in before you can comment on or make changes to this bug.