Error about copying to sent folder when I wasn't sending the message

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I'm in the middle of composing a message and all of a sudden it displays the following dialog:

There was an error copying the message to the Sent folder. Retry?

This is worrying, I haven't finished writing the mail yet and there is no chance I accidentally hit send. So I click cancel and see:

Unable to save your message as draft.
Please verify that your Mail & Newsgroups account settings are correct and try again.

So I guess it is trying to save the message as a draft and either ignoring the settings and trying to save it into the sent folder or the initial dialog has the wrong word in it.
Duplicate of this bug: 486419
As I wrote in Bug 485348 Comment #5, current Tb's behaviour upon "save in Drafts failure" was as follows (error is forced by "compact of Drafts" during compsing):
 If compaction of Drafts is in progress, "Save As Draft" or auto-save fails.
 => Error message(message you saw)  => Retry => draft     is saved in Sent
 => Dialog of "save in Sent or not" => OK    => 2nd draft is saved in Sent
 (because local mail folder case, error on Sent folder usually doesn't occur)
You can easiliy observe above by:
 - Enable dialog after "save in Drafts completion"
 - Enable confirmation dialog before start of auto-compact
 - Copy many mails to Drafts, delete some mails, compact Drafts,
   and "Save As Draft" during compact is in progress
If reply "Cancel" or IMAP + server or network error, fall back to Sent fails, and error message you saw or similar error message is displayed.

Phenomenon you saw is already reported to Bug 257735 for Thunderbird version 0.7+ (opened on 2009-02-06).
When "save in Drafts" fails, Mozilla looks to fall back to "Sent" since initial.
(probably inherited from Netscape 1, 2 etc.)

AFAIR, improvement of the misleading error message(user usually thinks "copy to Sent after send completion" failed) is already requested.
Tb 2 already has Tools/"Send a copy" feature for ad-hoc sent mail saving. I think behaviour itself is to be improved. (e.g. ask for alternate folder upon error, ad-hoc draft location). AFAIR, similar enhancemet is already requested.
Sorry but I can't recall bug numbers.

Comment 3

8 years ago
Within the last few days (late September 2010), I started getting this same message about an error copying the message to the Sent folder while I am composing the message.  This is followed by the message saying: Unable to save message as draft.

When I cancel the messages, they repeat every few minutes.  When I ultimately send the email, it sends OK, but a copy is not saved to the Sent mail folder.

The strange thing is that the messages occur fairly often but not with every email message.  Some messages go through the compose and send process with no problem at all.

Thunderbird version: 3.1.4
OS: Windows XP Pro
There is another known issue.
  auto-save is executed after send request and while sending mail.
If draft save error occurs and Tb tries to fall back to Sent, contention of Sent folder between auto-save and "save sent mail copy to Sent" can happen.
Check at least next.
1. "Manual copy of big mail to Drafts" ends normaly within ordinal time.
2. "Manual copy of big mail to Sent"   ends normaly within ordinal time.
If problem still occurs, enable dialog after draft save(Copies&Folders), execute Save As Draft just before send, wait for dialog, then execute Send.
Send Later and Send Unsent Messages is another operational workaround of your problem.

Comment 5

8 years ago
Mossop, Jon,

perhaps this will be fixed in 3.1.8 by Bug 257735 - Drafts wrongly saved to sent folder after failing and retrying (common issue of Drafts/Templates/Outbox==Unsent Messages)

can you test 3.1.8 candidate build * and report results here?
or 3.1.8 when it comes out in a couple weeks?

* ftp://ftp.mozilla.org/pub/thunderbird/nightly/3.1.8-candidates/build1/win32/
Wada (being the expert on these things...), can we close this (now that bug 257735 has been fixed)?
(In reply to Thomas D. from comment #6)
> Wada (being the expert on these things...), can we close this (now that bug
> 257735 has been fixed)?

Sorry but I can say nothing, because additional data is never provided by bug opener for more than 2.5 years. I believe that there is no reason to keep such useless bug report by user at B.M.O open.
But I'm never such decision maker at B.M.O.
Tomas D., if you think or believe that bug reports at B.M.O like this bug is merely wasting of resource of B.M.O, close such useless bug like this bug, please.
I believe that here, B.M.O, is never support forum.
Wada, thank you for reliable background information analysing the problems.

No response from reporters, reported against outdated version, and several candidates for resolving duplicate, as mentioned by Wada above -> resolving incomplete.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.