Closed Bug 476294 Opened 14 years ago Closed 5 years ago

Application update prompt exits fullscreen mode and steals focus

Categories

(Toolkit :: Application Update, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 893505

People

(Reporter: johnhoogstrate, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090124 Shiretoko/3.1b3pre
Build Identifier: 

The application update window for Firefox violently interrupts the workflow when the Flash plugin has entered fullscreen mode. The update window suddenly pops up in the middle of the screen, steals the focus and then disables the fullscreen mode and stays in the middle of the screen prompting the user to make a choice.

Updating the application should be as seamless as possible, the user should be bothered as less as possible about it and it should not interrupt the workflow. 

When automatic updates are enabled Firefox should simply display a notification (from the taskbar in Windows or using Growl on Mac OS X) that an update has been downloaded and will be installed when the browser is restarted. This whole "in your face" approach is just bothering users about technicalities and choices and should be avoided as much as possible.

Reproducible: Always
The initial notification uses an alert notification growl and 12 hours later it shows the update prompt along with the idle service (which likely doesn't respect plugins playing such as flash) to prevent interruption. Was Firefox open for 12 hours?

Since the alert notification can be easily missed I've been thinking about adding multiple notifications (perhaps 1 every hour) during the 12 hour wait.
Summary: Application update quits disables fullscreen mode and steals focus → Application update exits fullscreen mode and steals focus
Summary: Application update exits fullscreen mode and steals focus → Application update prompt exits fullscreen mode and steals focus
Firefox was probably running for over 12 hours. The latest builds seem to be quite stable. The preferences are set to automatically check for, download and install updates. These settings suggest that updating requires no user interaction. 

This is especially troublesome when using the browser in a kiosk mode, or on a presentation display. Users might be tempted to disable updates entirely to prevent these messages from popping up.
We got a lot of complaints about auto downloading / installing major updates due to add-ons being made incompatible so major updates haven't done this for quite some time. At the moment we are testing the major update code path which is why you are getting the prompt... we'll be reverting nightly updates to be minor updates after we bump the Firefox version which should happen some time in the next week.
(In reply to comment #3)
> We got a lot of complaints about auto downloading / installing major updates
> due to add-ons being made incompatible so major updates haven't done this for
> quite some time.
We also received complaints about the default being auto-update when updating to a major since not everyone wanted to update.

btw: the kiosk case doesn't apply. Kiosks by their very nature are customized, one of the customizations should be to disable update if the kiosk user has write access to the installation directory. Since the vast majority of kiosk users don't have write access to the installation directory updates won't be checked when running as a kiosk user.
Version: unspecified → Trunk
Duplicate of this bug: 522841
Duplicate of this bug: 426743
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
I experienced a similar issue today, running Firefox 15.1 (or was it 15.0.1? don't remember exactly, just updated to 16) on Windows Vista:

I was watching a video on YouTube (with Flash enabled) in full screen mode when the picture suddenly froze for a full second or two.  I thought I was just experiencing typical streaming video lag, but then the browser exited full screen and opened a new tab (and set focus to it) to announce that FireBug had just been been updated.

That was VERY annoying.
This also applies to (non-flash) html5 fullscreen mode.

1. The update popup appears
2. Firefox exits fullscreen
3. The update popup automatically disappears

All three steps happen within one second and without user input.
(Tested with Firefox 19.0 and notification for 19.0.2.)
Duplicate of this bug: 853846
This is fixed by the new doorhanger notification implemented in bug 893505
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893505
You need to log in before you can comment on or make changes to this bug.