Closed Bug 476623 Opened 15 years ago Closed 15 years ago

Automatic language detection when composing a new message

Categories

(Thunderbird :: Message Compose Window, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 69687

People

(Reporter: andreamonni, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: 

Lot of users compose emails in two or more languages, and change dictionary with the current spelling checker implementation is very complicated and time consuming.

Outlook and Mail.app implement automatic language detection, meaning that after typing a few words they automatically check against the installed dictionaries which language they most likely belong to and use the corresponding dictionary.

The Dictionary Switcher extension (can be found at http://en.design-noir.de/mozilla/dictionary-switcher-tb/ ) implemented such solution but it's not maintenaned anymore and, in any case, a native implementation in Thunderbird would be highly advisable. 

Reproducible: Always
Please check bugzilla before you file a report !
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
I apologize but when I did a search for automatic language detection that bug didn't come up, guess we should change the description in order to make it easier to find
two extensions that implement automatic
language detection in Thunderbird and Firefox reasonably well:

http://en.design-noir.de/mozilla/dictionary-switcher-tb/

http://en.design-noir.de/mozilla/dictionary-switcher/

It'd be a good idea to contact the author and ask him if he wants to work on integrating them in the code base.
i suggest to put this into the right-click-context-menu, similar to firefox

i currently use firefox 3.1b3 ("Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3") and this is working great
still dupe bug 69687 ;) sorry
It looks like most problems that users report with repeatedly choosing ONE spell checking language would be satisfactorily solved if the user could once for all setup SEVERAL dictionaries to be used SIMULTANEOUSLY for the languages he can write, among those installed on his system.  That is especially needed for e-mail since many people write them in several languages (and that's the way Evolution does it).
It seems fairly simple to do, see  https://bugzilla.mozilla.org/show_bug.cgi?id=676500
Not sure why this is a duplicate. It would be great if thunderbird will automatically choose the default dictionary per message, then let the user override it if it guessed wrong. This doesn't need multiple dictionaries enabled simultaneously.

There is a KDE library for automatic language detection:

https://github.com/KDE/sonnet

This will be useful in thunderbird.
You need to log in before you can comment on or make changes to this bug.