Last Comment Bug 477015 - Create namerules based tests for accessible name of images.
: Create namerules based tests for accessible name of images.
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Marco Zehe (:MarcoZ)
:
Mentors:
Depends on:
Blocks: 476796
  Show dependency treegraph
 
Reported: 2009-02-05 01:05 PST by Marco Zehe (:MarcoZ)
Modified: 2012-01-23 11:49 PST (History)
2 users (show)
mzehe: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (7.27 KB, patch)
2009-02-05 01:51 PST, Marco Zehe (:MarcoZ)
no flags Details | Diff | Review
Patch updated to trunk (7.27 KB, patch)
2009-02-19 06:34 PST, Marco Zehe (:MarcoZ)
surkov.alexander: review+
Details | Diff | Review

Description Marco Zehe (:MarcoZ) 2009-02-05 01:05:12 PST
Spun off bug 476796. The namerules architecture currently does not allow alt=  to be defined, which is used to specifically denote a decorative image, and whose accessible name must also be testable.
Comment 1 Marco Zehe (:MarcoZ) 2009-02-05 01:51:05 PST
Created attachment 360687 [details] [diff] [review]
Patch

Turns out that I could test this with two sets of rules and markup.
Comment 2 Marco Zehe (:MarcoZ) 2009-02-19 06:34:08 PST
Created attachment 363103 [details] [diff] [review]
Patch updated to trunk

The patch no longer applied cleanly to trunk. Updated.
Comment 3 alexander :surkov 2009-02-19 07:09:24 PST
Marco, thank you for keeping it up to dated.

I would prefer actually to introduce markup support for this special cases. Your way works but it might be not easy understandable. I'll think how to extend our tests to test null names.
Comment 4 Trevor Saunders (:tbsaunde) 2011-12-10 03:33:27 PST
ping? (going through surkov's reviews and found this)
Comment 5 alexander :surkov 2012-01-22 04:34:28 PST
Comment on attachment 363103 [details] [diff] [review]
Patch updated to trunk

I've never got around to think how to improve this. I think we can take the patch as it is.
Comment 6 Marco Zehe (:MarcoZ) 2012-01-23 00:14:58 PST
Inbound land: http://hg.mozilla.org/integration/mozilla-inbound/rev/e170001f3e9b
Comment 7 Ed Morley [:emorley] 2012-01-23 11:49:31 PST
https://hg.mozilla.org/mozilla-central/rev/e170001f3e9b

Note You need to log in before you can comment on or make changes to this bug.