Alt+S should send a message

VERIFIED DUPLICATE of bug 20336

Status

SeaMonkey
MailNews: Message Display
P3
enhancement
VERIFIED DUPLICATE of bug 20336
18 years ago
13 years ago

People

(Reporter: James "Kovu" Russell, Assigned: scottputterman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
In both ICQ and Outlook (which I'm forced to use at work) I can finish writing 
in the body of a message and merely press Alt+S to send the message. It's a 
beautiful keyboard shortcut, incredibly fast and intuitive, I think. It could be 
Command+S on Mac? It's becoming a familiar shortcut, and I think we should use 
it.
(Assignee)

Comment 1

18 years ago
currently it's used to save a message.
Target Milestone: --- → Future
(Reporter)

Comment 2

18 years ago
I think Ctrl+S is the better standard for Save.

Making Alt+S a "Send" would involve adding hotkeys to the buttons on the 
toolbar, which makes all of the most often-used features intuitively keyboard 
accessible, since you can see what the hotkey is by the button. Currently the 
keyboard shortcut for sending a message is Alt+F+D, which I never use. 
Attach a file is Alt+F+H. I just don't think these are very intuitive.

Anyway, that's how it's done it Outlook. Granted, otherwise I hate the program, 
but I think adding hotkeys to the icons is a good way to make keyboard 
shortcuts more accessible and obvious to the user, as well as making the 
program more functional. Just make sure that the letters used on the buttons 
don't cross those used for the menus and you've got it. 

Anyway, given how fast the shortcut is, I would argue giving it to this function 
makes more sense. Saving messages just doesn't happen nearly as often as sending 
them.
(Reporter)

Updated

18 years ago
Depends on: 55679

Comment 3

17 years ago
Making Ctrl-S send a message would be likely to cause users to acidentally send 
drafts.  Is Ctrl-E open?
(Reporter)

Comment 4

17 years ago
You mean Alt+E? The shortcut is Alt+, not Ctrl+, and is identical on ICQ and
Outlook. I would go with S. E isn't very intuitive for "send" and in any case it
isn't much farther from S on the keyboard. I'd prefer sticking with Alt+S.

JR

Updated

17 years ago
QA Contact: lchiang → nbaca

Comment 5

17 years ago
Duplicate of bug# 20336 where it discusses what key sequence should be used to
send a message.

*** This bug has been marked as a duplicate of 20336 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.