Closed Bug 477113 Opened 11 years ago Closed 10 years ago

Investigate RTL text-align changes throughout the theme because of bug 299837

Categories

(Toolkit :: Themes, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.3a4

People

(Reporter: ehsan, Assigned: dao)

References

()

Details

(Keywords: rtl)

Attachments

(2 files)

Bug 299837 implements "text-align: end", and also fixes the meaning of "left" and "right" for the text-align CSS rule in RTL mode.  This may have some subtle effects on the themes for different platforms, so I'll do this investigation in this bug and attach a patch as needed.
To be precise, the meaning of "text-align: right" is only affected for:

  <xul:treecol>
  <xul:label>

and the meaning of "text-align: left" is only affected for <xul:label>.
(In reply to comment #2)
> patch forthcoming.

hm? :)
Attached patch patchSplinter Review
Assignee: ehsan.akhgari → dao
Attachment #432520 - Flags: review?(ehsan.akhgari)
Component: Theme → Themes
Product: Firefox → Toolkit
QA Contact: theme → themes
Comment on attachment 432520 [details] [diff] [review]
patch

>--- a/toolkit/themes/pinstripe/global/datetimepicker.css
>+++ b/toolkit/themes/pinstripe/global/datetimepicker.css
>@@ -60,21 +60,17 @@ datepicker, timepicker {
>   color: -moz-FieldText;
> }
> 
> .datetimepicker-input-subbox {
>   width: 1.6em;
> }
> 
> html|*.datetimepicker-input {
>-  text-align: right;
>-}
>-
>-html|*.datetimepicker-input:-moz-locale-dir(rtl) {
>-  text-align: left;
>+  text-align: end;
> }

I wonder whether this should always be right...
Comment on attachment 432520 [details] [diff] [review]
patch

Thanks for picking up my slack!

(In reply to comment #5)
> (From update of attachment 432520 [details] [diff] [review])
> >--- a/toolkit/themes/pinstripe/global/datetimepicker.css
> >+++ b/toolkit/themes/pinstripe/global/datetimepicker.css
> >@@ -60,21 +60,17 @@ datepicker, timepicker {
> >   color: -moz-FieldText;
> > }
> > 
> > .datetimepicker-input-subbox {
> >   width: 1.6em;
> > }
> > 
> > html|*.datetimepicker-input {
> >-  text-align: right;
> >-}
> >-
> >-html|*.datetimepicker-input:-moz-locale-dir(rtl) {
> >-  text-align: left;
> >+  text-align: end;
> > }
> 
> I wonder whether this should always be right...

No, it should be left in RTL mode, and actually this patch makes things work, because :-moz-locale-dir is not supported for HTML elements!

(I trust that removal of plugins.css is OK, it seemed to be pointing to empty-file right now.)
Attachment #432520 - Flags: review?(ehsan.akhgari) → review+
Fixed winstripe's datetimepicker.css too, based on comment 6.
(In reply to comment #7)
> Created an attachment (id=432605) [details]
> what I'm going to land
> 
> Fixed winstripe's datetimepicker.css too, based on comment 6.

Seems good!
http://hg.mozilla.org/mozilla-central/rev/69cb1df1cb0f
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a4
Duplicate of this bug: 426516
You need to log in before you can comment on or make changes to this bug.