Wrong use of term "Sender"

VERIFIED DUPLICATE of bug 40934

Status

P3
normal
VERIFIED DUPLICATE of bug 40934
18 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: BenB)

Tracking

({polish})

Trunk
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
In the threadpane the term "Sender" is used, while in the messagepane the term 
"From" is used.
Why confuse users with two different words describing the same thing?????

Comment 1

18 years ago
moving to future milestone.

I'm not really sure of the history behind it.
Target Milestone: --- → Future
(Assignee)

Comment 2

18 years ago
No, please not future. It is easy to fix. If I get OK, I can do the change.
REASSINGing to me.

Using the term "Sender" for the content of the "From" header is wrong.

See RFC822:
"From" header = author(s)
"Sender" header = sender.
Only if no "Sender" header exists, then "From" header = author = sender.
Assignee: putterman → mozilla
Keywords: polish
Summary: Inconsistency between Sender and From → Wrong use of term "Sender"
Target Milestone: Future → ---
(Assignee)

Comment 3

18 years ago
putterman: OK?
Status: NEW → ASSIGNED

Comment 4

18 years ago
We don't have any problem with changing it, but we also don't think there's
anything wrong with leaving it the way it is now. I think people can figure out
what it means when it says "Sender" and "Sender" does accurately describe what
the column represents.
(Assignee)

Comment 5

18 years ago
> We don't have any problem with changing it

So, if I submit patches, they will be accepted (or at least not rejected with
the rationale "I don't think that's the right thing to do.")?

> "Sender" does accurately describe what the column represents.

What makes you think that??
(Reporter)

Comment 6

18 years ago
Also remember to change the "Sender" in fx the search mailnews dialog. I (and 
advanced user) find it *very* confusing that the header in the message pane *is* 
called "From" but you can't fx search using the header "From", but only 
"Sender"....

Comment 7

18 years ago
My point is that I don't think many people are confused by the way it is and
that this probably isn't any kind of a hindrance in people's use of mail.



(Assignee)

Comment 8

18 years ago
putterman, sure, this is not really dogfood :). I am assuming, it is OK to fix
this bug. If not, tell me now. Targetting M18.
Target Milestone: --- → M18

Comment 9

18 years ago
I guess I'm saying I don't think this is a bug :)

But, if you really think this is a problem, then you can change it.

Comment 10

18 years ago
I'm changing my mind. I  think we should just leave it the way it is.
(Assignee)

Comment 11

18 years ago
Are you kidding me?

Why???

Comment 12

18 years ago
Netscape 4 is biting me on sender so I now have 'sender' and 'Sender'
please consider using 'Author' and 'Sender'.  Maybe we need tool tips or help 
or something.  But we can't leave sender to mean from.
Keywords: ui
(Assignee)

Comment 13

18 years ago

*** This bug has been marked as a duplicate of 40934 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 14

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.