Copy should be added to e-mail address context menu

VERIFIED FIXED

Status

P3
minor
VERIFIED FIXED
19 years ago
7 years ago

People

(Reporter: bugzilla, Assigned: gerv)

Tracking

({polish})

Trunk
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

19 years ago
When you right-click on a e-mail address in the header field of the messagepane, 
Copy should appear in the context menu.

Currently the context menu only has:
 Add address to address book
 Send mail to

The Copy would copy the email address to the clipboard.

Comment 1

19 years ago
moving to future milestone and reassigning to mscott.
Assignee: putterman → mscott
Target Milestone: --- → Future

Comment 2

18 years ago
I think this context menu should share menu items with the mailto: link context 
menu in bug 32358.  Then we'd automatically have the same mnemonics in both 
menus, and internationalization teams would have fewer things to translate.

See also discussion in bug 57578 about removing this context menu :(

Updated

18 years ago
Summary: Copy should be added to a-mail address context menu → Copy should be added to e-mail address context menu

Comment 3

18 years ago
The context menu for these addresses should be the same as for any other e-mail 
address link in a Web page or e-mail message -- though the default item would be 
different (`Add to Address Book ...' for an address in the header pane, vs. `New 
Message' in Web page/message content).

Bug 57578 isn't about removing the context menu, it is about turning the current 
compulsory menu into a context menu.

Comment 4

18 years ago
nominating nsbeta1 to add copy to the menu.
Keywords: nsbeta1

Updated

18 years ago
QA Contact: lchiang → laurel

Comment 5

18 years ago
marking nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Updated

18 years ago
Severity: normal → trivial
Keywords: polish, ui

Updated

18 years ago
Severity: trivial → minor
*** Bug 54894 has been marked as a duplicate of this bug. ***
*** Bug 63023 has been marked as a duplicate of this bug. ***
OK - patches coming right up. I would appreciate review of these :-) 

Resetting target milestone and nsbeta1 nomination for retriage...

Hope they work - my editor does funny things with the tabs in the file, so 
there's been a little hand-hackery of the patches.

Gerv
Keywords: nsbeta1- → mozilla0.9, mozilla1.0, nsbeta1, patch, review
Target Milestone: Future → ---
Created attachment 28392 [details] [diff] [review]
Patches to content files

Comment 11

18 years ago
Code looks okay to me, but the documentation for CopyEmailAddress is incorrect.

r=adamlock
Thanks! :-) Fixed. Now who do I go to for an sr=?

Gerv

Updated

18 years ago
Blocks: 32358

Comment 13

18 years ago
marking nsbeta1-, but of course, since Gervase has a patch it would be cool if
this got in.
Keywords: nsbeta1 → nsbeta1-

Comment 14

18 years ago
*** Bug 73616 has been marked as a duplicate of this bug. ***
Created attachment 28912 [details] [diff] [review]
Updated diff - looking for sr=

Comment 16

18 years ago
Oops, this bug doesn't block bug 32358, since for now the context menu for e-
mail addresses in mailnews xul is different from the context menu for e-mail 
addresses in html content.
No longer blocks: 32358

Comment 17

18 years ago
r=timeless
Assignee: mscott → gervase.markham
Keywords: mozilla1.0, nsbeta1-, review → approval
sspitzer - any chance of a sr= here? :-) 

[ Sidenote: you and dveditz get the prize for the people whose name is most 
often misspelt in checkin comments...]

Gerv

Updated

18 years ago
Depends on: 75338
Created attachment 31517 [details] [diff] [review]
New patch - old one had rotted slightly

Comment 20

18 years ago
sr=alecf assuming we get approval/review from a mail person
sspitzer, mscott or bienvenu: This bug has r= and sr=, it just needs a "Yes,
we'd like that" from someone in mail/news. Can that be provided?

I know Asa wants this really badly ;-)

Gerv

Comment 22

18 years ago
I'd like to see this land for 0.9 if mail-news folks are OK with it. 
Whiteboard: would like for 0.9

Comment 23

18 years ago
fine with me, if that's sufficient.
It just needs someone to check it in, then. I can't, and I'm going to bed anyway
:-)

Gerv

Comment 25

18 years ago
fix by Gervase Markham mailto:gervase.markham@univ.ox.ac.uk checked in. Sorry 
gerv i messed up the cvs comment.

If anyone has any problems with this bug please open a new one against gerv or 
me cc the other and cite this bug. I'm very sorry.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: would like for 0.9

Comment 26

18 years ago
OK using apr23 commercial trunk build. Win98, linux rh6.2, mac OS 9.0
Context menu item present and functional from mail and news header envelopes.
Any other issues with this item will be logged separately.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.