TestHarness.h should print the magic keywords for making failures show up in the tinderbox log

RESOLVED FIXED in mozilla1.9.2a1

Status

Testing
XPCShell Harness
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

Trunk
mozilla1.9.2a1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

9 years ago
TestHarness.h has code to print info about failures.  However, it just prints "FAIL", which isn't enough to make it show in the tinderbox log highlighting.  It should instead print TEST-UNEXPECTED-FAIL.

http://mxr.mozilla.org/mozilla-central/source/xpcom/tests/TestHarness.h

This was an issue when bug 88831 about 36 hours ago.

We might also want to check other TUnit tests.
(Assignee)

Comment 1

9 years ago
Created attachment 361597 [details] [diff] [review]
patch

Bug 477867 limited my testing a little bit, but it seems to work fine.
Attachment #361597 - Flags: review?(jwalden+bmo)
Attachment #361597 - Flags: review?(jwalden+bmo) → review+
Duplicate of this bug: 468033
Assignee: nobody → dbaron
(Assignee)

Comment 3

9 years ago
Created attachment 361657 [details] [diff] [review]
fix the pass function too
Attachment #361657 - Flags: review?(jwalden+bmo)
(Assignee)

Comment 4

9 years ago
And I'll fix the comment too.
(Assignee)

Comment 5

9 years ago
http://hg.mozilla.org/mozilla-central/rev/561dc7d5c746
Comment on attachment 361657 [details] [diff] [review]
fix the pass function too

Hm, how'd I forget this part too?
Attachment #361657 - Flags: review?(jwalden+bmo) → review+
(Assignee)

Comment 7

9 years ago
http://hg.mozilla.org/mozilla-central/rev/af294f0d2c6a
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Can you land this on 1.9.1 too?
(Assignee)

Comment 9

9 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/225b2acca344
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/52c7f8c43bbd
You need to log in before you can comment on or make changes to this bug.