[X11] font-family: cursive and fantasy render as sans-serif

NEW
Unassigned

Status

()

Core
CSS Parsing and Computation
P4
normal
17 years ago
10 months ago

People

(Reporter: Tobias Burnus, Unassigned)

Tracking

({css1, testcase})

Trunk
Future
x86
Linux
css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CSS1-5.2.2], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
This is with a suse linux system with bunches of default fonts installed. (but
not TT server). 2000-08-04-21.
Go to the given page. The cursive and fantasy render as sans-serif, but slightly
different than sans-serif. At least cursive should be treated correctly
(Chancery I is available)
Specs:
http://www.w3.org/TR/REC-CSS2/fonts.html#generic-font-families

Comment 1

17 years ago
Wow on my machine fantasy and cursive are rendered in a character cell font. 
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
The default fonts are fine on Mac and Windows. Reassigned to Erik to fix the 
defaults on Unix.
Assignee: pierre → erik

Comment 3

17 years ago
Of course, this is related to bug 28899.

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 4

17 years ago
reassign to bstell and keep it as Future
Assignee: erik → bstell
Status: ASSIGNED → NEW

Updated

17 years ago
Status: NEW → ASSIGNED
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian

Comment 6

17 years ago
I'm seeing this on 2001051704 Win98. Cursive is rendered in Comic Sans, even
though I have cursive fonts installed such as Brush Script. Will attach testcase.

Comment 7

17 years ago
Created attachment 35360 [details]
Generic font family testcase

Comment 8

16 years ago
--> ftang
Assignee: bstell → ftang
Status: ASSIGNED → NEW

Comment 9

16 years ago
bulk move NEW FUTURE bug to ASSIGN
Status: NEW → ASSIGNED
Keywords: testcase
Whiteboard: [CSS1-5.2.2]

Comment 10

16 years ago
I still see this on redhat linux 7.3 - buildID: 2002-05-12-23-XX-PR1

Comment 11

16 years ago
in win2000 : buildID 2002-05-12-20-XXPR1 ==> The cursive font shows up bold 

in macOS9.1 : buildID 2002-05-12-17-XXPR1 ==> the fantasy font shows up bold

Comment 12

15 years ago
WFM. Everything look Ok with mozilla 1.0 on Win98.

I tested Lucida Handwriting as the comic font and Tempus Sans ITC as the fantasy
font.
The point of this bug is that the Unix defaults aren't good, not that it doesn't
work if you override the defaults.

Comment 14

15 years ago
Created attachment 113088 [details]
diffrent rendering of same CSS

same CSS styles but mozilla renders them in diffrent ways

Comment 15

15 years ago
Comment on attachment 113088 [details]
diffrent rendering of same CSS

Changing text/plain to text/html since it is clearly the latter.

However, this testcase is still invalid because you cannot put multiple font
names into one set of double quotes. Please refer to
<http://www.w3.org/TR/REC-CSS1#font-family> for the proper way to quote font
names.
Attachment #113088 - Attachment is obsolete: true
Attachment #113088 - Attachment mime type: text/plain → text/html

Comment 16

14 years ago
This still appears to be a problem with firefox-0.8, which doesn't have any GUI
method of changing the defaults.  (Should that be a separate bug?)

Comment 17

13 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 18

13 years ago
(Why not just reassign ?)

Comment 19

13 years ago
Mass Re-assigning bugs that Frank Tang Closed on March 1st Spam is his fault

Mass Re-Open to follow
Assignee: ftang → nobody

Comment 20

13 years ago
Mass Bug Re-Open of bugs Frank Tang Closed with no good reason. Spam is his
fault not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 21

13 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW

Updated

13 years ago
Keywords: css1
QA Contact: ian → style-system

Updated

7 years ago
Duplicate of this bug: 622179

Comment 23

7 years ago
Also in the new Firefox 3.6.13 the old rendering-problem of cursive (and fantasy, too) font-families on a Linux-system stays alive.

Comment 24

7 years ago
Today is January the 3th in the year 2011. Iam using Firefox 3.6.9 on Ubuntu 10.04 with Linux Kernel 2.6.32. The font "URW Chancery L" is installed and works fine. The following css definition:

.name_produkt {font-family:Monotype Corsiva,'Monotype Corsiva','Apple Chancery','ITC Zapf Chancery','URW Chancery L',cursive; letter-spacing:90%;font-size:150%; color:#000066;}

will be rendered with the default sans-serif font (???)

I cannot believe that a full-featured browser like Firefox does not handle such an easy job. Perhaps Opera will make it better...
In my opinion complicated bugs like this need more time to fix.
Please don't panic!
Priority: P3 → P4

Comment 26

6 years ago
Still not working on FF 10.0. I think we must be in panic. :-(
While playing around with generic fonts, I notices that URW Chancery only gets rendered (in ubuntu 11.10) if you also set the font style to itallic.  Font-config also shows the font as itallic. 
$ fc-list |grep URW |grep Chancery
URW Chancery L:style=Medium Italic

Just another data point (before I forget)

Comment 28

5 years ago
There is a CSS validation error in the test of attachment 35360 [details] , although it should not interfere with the test.

My test:

http://www.gtalbot.org/BrowserBugsSection/MozillaBugs/Bug47752-cursive-fantasy-rendered-as-sans-serif.html

Opera 12.0 and Konqueror 4.8.4 pass this test.

Firefox 14.0.1 and Chrome 20.0.1132.57 fail this test.

I have set URW Chancery L font for cursive and Purisa font for fantasy.

Linux Kubuntu KDE 4.8.4, 
kernel 3.2.0-27-generic-pae (i686, 32bits)
here.

-----------------


(In reply to OutOfLinn from comment #24)

> Iam using Firefox 3.6.9 on Ubuntu
> 10.04 with Linux Kernel 2.6.32. The font "URW Chancery L" is installed and
> works fine. The following css definition:
> 
> .name_produkt {font-family:Monotype Corsiva,'Monotype Corsiva','Apple
> Chancery','ITC Zapf Chancery','URW Chancery L',cursive;
> letter-spacing:90%;font-size:150%; color:#000066;}
> 
> will be rendered with the default sans-serif font (???)

I got intrigued by your comment and made more tests and there is definitely an issue. A simple h1 {font-family: "URW Chancery L";} test:

http://www.gtalbot.org/BrowserBugsSection/MozillaBugs/OutOfLinnBug47752-cursive-test.html

Opera 12, Chrome 20.0.1132.57 and Konqueror 4.8.4 pass this test.

Firefox 14.0.1 fails this test.



I think people commenting in this bug report should try to understand that, from an outside perspective, it may seem that this bug should be easy to fix but, from the inside, it may be a lot more difficult to fix; eg bugs that require module rewrites are not easy and not simple to fix.

Gérard
(In reply to Gérard Talbot from comment #28)
> I think people commenting in this bug report should try to understand that,
> from an outside perspective, it may seem that this bug should be easy to fix
> but, from the inside, it may be a lot more difficult to fix; eg bugs that
> require module rewrites are not easy and not simple to fix.

That's not the case here.

The underlying problems here are:
 * it's not clear what good defaults for cursive and fantasy would be, across different scripts (Latin, Cyrillic, Greek, Arabic, Hebrew, Chinese, etc.) and operating systems (though this bug is primarily about Linux or other X11-based desktops), since the categories are large and widely varying -- or, for that matter, why an author would choose such a default (which ought to help us choose them)
 * (indirectly related to this bug, but not directly related) it's not clear why we should complicate the browser UI with mechanisms for changing these defaults when the number of pages that would be affected by such defaults is so small

The main work to be done here is to do research on the first point and figure out what the commonly installed fantasy and cursive fonts across distros and across scripts are and which ones would make sense as the defaults.
Assignee: jshin1987 → nobody
Summary: font-family: cursive and fantasy render as sans-serif → [X11] font-family: cursive and fantasy render as sans-serif

Comment 30

5 years ago
(In reply to David Baron [:dbaron] from comment #29)
> The main work to be done here is to do research on the first point and
> figure out what the commonly installed fantasy and cursive fonts across
> distros and across scripts are and which ones would make sense as the
> defaults.


Most common cursive fonts on Linux to 5 April 2012 
Font name 	Installed (%) 
URW Chancery L	99.01%
Comic Sans MS	68.44%
Purisa	        63.70%
Vemana2000	62.38%
Domestic Manners12.80%	

http://www.codestyle.org/css/font-family/sampler-Cursive.shtml

Most common fantasy fonts on Linux to 5 April 2012 
Font name 	Installed (%)
Impact	        68.84%	
Penguin Attack	10.41%
Balker	        9.98%	
Marked Fool	9.98%
Junkyard	9.54%
Linux Biolinum O8.75%
http://www.codestyle.org/css/font-family/sampler-Fantasy.shtml


Complete Guide to Pre-Installed Fonts in Linux (only Ubuntu), Mac, and Windows
by Megan McDermott, 19 March 2012
http://www.apaddedcell.com/web-fonts/

"
Ubuntu is used as a sample Gnu/Linux operating system. Other distributions may have different fonts installed.
"

http://www.apaddedcell.com/sites/www.apaddedcell.com/files/fonts-article/final/index.html

"URW Chancery L" as a cursive font is installed in Ubuntu 11.10 and 12.04 and in Kubuntu 12.04. And h1 {font-family: "URW Chancery L";} fails in Firefox 14.0.1.

Gérard

Comment 31

5 years ago
Reposting this because there were anchors (better linking)

Most common cursive fonts on Linux to 5 April 2012 
Font name 	Installed (%) 
URW Chancery L	99.01%
Comic Sans MS	68.44%
Purisa	        63.70%
Vemana2000	62.38%
Domestic Manners12.80%	

http://www.codestyle.org/css/font-family/sampler-Cursive.shtml#cursive-linux



Most common fantasy fonts on Linux to 5 April 2012 
Font name 	Installed (%)
Impact	        68.84%	
Penguin Attack	10.41%
Balker	        9.98%	
Marked Fool	9.98%
Junkyard	9.54%
Linux Biolinum O8.75%
http://www.codestyle.org/css/font-family/sampler-Fantasy.shtml#fantasy-linux
You need to log in before you can comment on or make changes to this bug.