If Send Unsent Messages fails, then you can't re-attempt in the same session.

RESOLVED FIXED in Thunderbird 3.0b2

Status

MailNews Core
Networking: SMTP
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

Trunk
Thunderbird 3.0b2
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 361262 [details] [diff] [review]
The fix

Steps to repeat:

1) Set up an smtp failure such that the server is missing.
2) Write a message, select to send later.
3) Select Send Unsent Messages
4) Acknowledge failure
5) Try to select Send Unsent Messages

=> You can't.

The problem is that the failure route doesn't call StartNextMailFileSend, which is related to bug 151364. However, whenever we stop sending unsent mail, we should make sure we clear the mSendingProgress flag. I noticed a couple of instances where if StartNextMailFileSend fails, NotifyListenersOnStopSending is called, so it seems the correct thing to do is to reset mSendingProgress in the NotifyListenersOnStopSending function.

Patch attached with test case.
Attachment #361262 - Flags: superreview?(bienvenu)
Attachment #361262 - Flags: review?(bienvenu)

Updated

9 years ago
Attachment #361262 - Flags: superreview?(bienvenu)
Attachment #361262 - Flags: superreview+
Attachment #361262 - Flags: review?(bienvenu)
Attachment #361262 - Flags: review+

Comment 1

9 years ago
Comment on attachment 361262 [details] [diff] [review]
The fix

+  // Ensure we have a local mail account, an normal account and appropriate
+  // servers and identities.

should be "a normal account"
(Assignee)

Comment 2

9 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/e79acef645e3
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.