Closed Bug 477634 Opened 11 years ago Closed 10 years ago

[SeaMonkey, Linux] intermittent Mochitest test_videocontrols.html timeout

Categories

(Toolkit :: Video/Audio Controls, defect)

1.9.1 Branch
x86
Linux
defect
Not set

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: sgautherie, Unassigned)

References

Details

(Keywords: intermittent-failure, regression)

It looks like this is a recent regression:
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1234099234.1234103831.27661.gz
Linux comm-central dep unit test on 2009/02/08 05:20:34
*** 81897 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols.html | Test timed out.
}
which occurs rather frequently:
{
Linux comm-central dep unit test on 2009/02/08 21:07:28
Linux comm-central dep unit test on 2009/02/08 22:19:14
Linux comm-central dep unit test on 2009/02/09 00:07:28
Linux comm-central dep unit test on 2009/02/09 02:59:51
Linux comm-central dep unit test on 2009/02/09 05:11:58
Linux comm-central dep unit test on 2009/02/09 06:18:35
}

A recent checkin was
{
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/c8099a4c91c3
Sat Feb 07 17:30:13 2009 -0800
Disable a check in test_videocontrols.html due to bug 477434 (videocontrols test encounters incorrect seeking behavior)
}
but I'm can't be sure this is the cause as there is a 12h delay between the two of them.
Flags: wanted1.9.1?
*** 81896 INFO Running /tests/toolkit/content/tests/widgets/test_videocontrols.html...
NEXT ERROR *** 81897 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_videocontrols.html | Test timed out.

The test isn't generating any output at all, which implies it never got the initial "load" event from the video, or failed even earlier.
Flags: wanted1.9.1? → wanted1.9.1+
Whiteboard: [orange]
Either this is still happening (despite no mentions recently), or it has just started again:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1255578475.1255580693.15850.gz
Ah, yes, this occurrence was caused by bug 521359 landing.  A fix was pushed: http://hg.mozilla.org/mozilla-central/rev/d71b94c523e0
This hasn't happened for several months, until I just broke and refixed it, so I think we should close this so people don't think it's a "known bug".
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Actually WORKSFORME, since we don't know what fixed the original incarnation.
Resolution: FIXED → WORKSFORME
Did not happen between 2009/10/08 22:33:02 and 2009/10/15 10:26:46 on SeaMonkey 2.0 boxes:
V.WorksForMe
Status: RESOLVED → VERIFIED
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio
Version: 1.9.1 Branch → unspecified
Version: unspecified → 1.9.1 Branch
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.