Links from external programs always open in current tab

RESOLVED DUPLICATE of bug 469082

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 469082
8 years ago
4 years ago

People

(Reporter: Mark Parnell, Unassigned)

Tracking

3.5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

Prior to installing the beta of 3.1 I had FF configured to open links from external programs in a new tab (I believe this is the default).

Since installing the beta (b2 - I didn't install b1), links from external programs now always open in the current tab, and the corresponding option (Tools>Preferences>Tabs>Open links in other applications in...) has disappeared. I checked about:config and browser.link.open_external was not there at all, however adding it and setting it to 3 (which should tell it to open external links in a new tab - see http://kb.mozillazine.org/Browser.link.open_external) has no effect.

Reproducible: Always

Steps to Reproduce:
1. Install 3.1b2
2. Click on a link in an external program
Actual Results:  
Link opens in current tab

Expected Results:  
Link should be opened in new tab.

I'm assuming this affects all platforms, though I've only tested it on Windows.

I believe this is a major regression - I'm seriously considering going back to 3.0 until it's fixed.
(Reporter)

Updated

8 years ago
Flags: blocking-firefox3.1?
Version: unspecified → 3.1 Branch

Comment 1

8 years ago
Would you check that this issue is reproducible in Firefox's safe mode and a new profile if safe mode fails to resolve the issue. http://support.mozilla.com/kb/Basic+Troubleshooting
Version: 3.1 Branch → unspecified

Updated

8 years ago
Version: unspecified → 3.1 Branch
Clearing the blocking nomination until we get a confirmation. Mark: we're not saying that your problem isn't real, just that you're the only person who's reporting it, and with 350,000 users on beta2, we'd expect to have heard about this before now. Please follow Kevin's request in comment 1 and let us know if the problem persists.
Flags: blocking-firefox3.1?
(Reporter)

Comment 3

8 years ago
Looks like it's profile related - Safe Mode didn't fix it, but in a new profile the behaviour is correct.

Now to try and work out why, and whether I can fix it, or whether I need to transfer everything across to a new profile...

Thanks guys, sorry for wasting your time.

Comment 4

8 years ago
See http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox.

Comment 5

8 years ago
I'm seeing the same issue. Haven't had a problem for a long time with tabs but after upgrading to FF 3.5, the browser.link.open_external option seems to do nothing at all for me and instead does whatever browser.link.open_newwindow says. Have tried in both safe mode and with a fresh profile, but neither seems to help.

Here's what I have configured:

browser.link.open_external = 3 (default; i.e. open in new tab)
browser.link.open_newwindow = 1 (not default; i.e. force new windows into the same tab rather than opening a new tab)
browser.link.open_newwindow.restriction = 2 (default)

With the above settings in FF 3.5, links from an external application *always* open in the current tab (=annoying and destructive). I've tried all the different settings of browser.link.open_external and it is ignored in all cases.

Out of curiosity, I tried setting browser.link.open_newwindow.restriction to 1, but that didn't change the external link behaviour. In all cases it seems that browser.link.open_newwindow is governing what happens with external links, regardless of the setting of browser.link.open_external.

Running on Fedora Linux: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.1) Gecko/20090630 Fedora/3.5-1.fc11 Firefox/3.5

Comment 6

8 years ago
I am having the same issue, exactly as described, in 3.5. Looks like the option disappeared at some point during the RC phase.

The handling of external links is now completely broken. Clicking an external link should _never_ be taken to mean that the user wants to navigate away from the page in the current tab. Every other browser and every other program that supports multiple documents in a single interface opens external links/opened files in a new tab/window.

Comment 7

8 years ago
The problem is that the behaviour of browser.link.open_newwindow and browser.link.open_newwindow.restriction has changed in 3.5, which has broken people's preferences.

It used to be possible to have external links open in a new tab, but links on web pages always open in the same tab. Now external links follow the in-page links behaviour and thus trash the current tab.

There does not appear to be a fix for this. No extension offers the same functionality, and there is no combination of preferences that do.

Devs, please don't break old preference behaviour, please use new ones to set up new features.

Updated

8 years ago
Duplicate of this bug: 503805

Updated

8 years ago
Flags: blocking-firefox3.6?

Comment 9

8 years ago
Is this a dup of bug #469082?

Comment 10

8 years ago
Here is an add-on that fixes it:

http://soft.world3.net/tabsopenrelative.html

It will be on the main add-ons site once it gets updated.

Comment 11

8 years ago
(In reply to comment #9)
> Is this a dup of bug #469082?

Confirmed!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 469082
Flags: blocking-firefox3.6?
You need to log in before you can comment on or make changes to this bug.